summary refs log tree commit diff
path: root/gnu/packages/flashing-tools.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-05-25 10:28:07 +0300
committerLudovic Courtès <ludo@gnu.org>2024-05-31 13:55:44 +0200
commit8944fa5c7a1283787fd316f505e83799e92867a9 (patch)
tree007cd9ab46cab24ec901696b39c6c72779989275 /gnu/packages/flashing-tools.scm
parent3e19432416e55dc8df426652a4c325ac2fd8b81c (diff)
downloadguix-8944fa5c7a1283787fd316f505e83799e92867a9.tar.gz
gnu: avrdude: Update to 7.3.
* gnu/packages/flashing-tools.scm (avrdude): Update to 7.3.
  [source]: Set to "https://github.com/avrdudes/avrdude/" as the project
  repository moved to GitHub.
  [build-system]: Use "cmake-build-system".
  [arguments]: Disable tests as there are none.
  [description]: Improve formatting.

Change-Id: I835563a6301d01089a9bfc2b1c3eb5050c4adb8f
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/flashing-tools.scm')
-rw-r--r--gnu/packages/flashing-tools.scm22
1 files changed, 13 insertions, 9 deletions
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 2629bafbe4..457f575c92 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -149,15 +149,19 @@ brick your device.")
 (define-public avrdude
   (package
     (name "avrdude")
-    (version "6.3")
+    (version "7.3")
     (source
      (origin
-      (method url-fetch)
-      (uri (string-append "mirror://savannah/avrdude/avrdude-"
-                          version ".tar.gz"))
+      (method git-fetch)
+      (uri (git-reference
+            (url "https://github.com/avrdudes/avrdude/")
+            (commit (string-append "v" version))))
+      (file-name (git-file-name name version))
       (sha256
-       (base32 "15m1w1qad3dj7r8n5ng1qqcaiyx1gyd6hnc3p2apgjllccdp77qg"))))
-    (build-system gnu-build-system)
+       (base32 "0g7c30baaxav43rlfj0cdbl40p2swamp44glz0rgf096wc0bg996"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:tests? #f))                      ; no tests
     (inputs
      (list libelf libusb-compat libftdi))
     (native-inputs
@@ -165,9 +169,9 @@ brick your device.")
     (home-page "https://www.nongnu.org/avrdude/")
     (synopsis "AVR downloader and uploader")
     (description
-     "AVRDUDE is a utility to download/upload/manipulate the ROM and
-EEPROM contents of AVR microcontrollers using the @acronym{ISP, in-system
-programming} technique.")
+     "@code{AVRDUDE} is a utility to download/upload/manipulate the ROM and EEPROM
+contents of AVR microcontrollers using the @acronym{ISP, in-system programming}
+technique.")
     (license license:gpl2+)))
 
 (define-public dfu-programmer