summary refs log tree commit diff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-09-26 23:08:44 +0800
committerTobias Geerinckx-Rice <me@tobias.gr>2023-09-24 02:00:00 +0200
commitb268842ec4808f5030f3bda95f52ff39dd88e3ad (patch)
tree8c5037547b9d81d04df9ecdba5e264378c2bebf1 /gnu/packages/fontutils.scm
parent848db3c7183d23785854716ba7c0fd8309f32d98 (diff)
downloadguix-b268842ec4808f5030f3bda95f52ff39dd88e3ad.tar.gz
gnu: psautohint: Disable flaky tests.
* gnu/packages/fontutils.scm (psautohint)[arguments]: Disable tests
test_hashmap_no_version and test_hashmap_old_version.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 18697cd821..c781ae2baf 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -789,9 +789,18 @@ suite of the @code{psautohint} package.")
     (build-system pyproject-build-system)
     (arguments
      (list
-      ;; The CJKSparseVar.subset.hinted.otf test fails with slightly different
-      ;; output caused by the newer fonttools version used in Guix.
-      #:test-flags #~(list "-k" "not CJKSparseVar.subset.hinted.otf")
+      #:test-flags
+      #~(list "-k"
+              (string-join
+               '(;; The CJKSparseVar.subset.hinted.otf test fails with slightly
+                 ;; different output caused by the newer fonttools version used
+                 ;; in Guix.
+                 "not CJKSparseVar.subset.hinted.otf"
+                 ;; These tests fails underministically, See also:
+                 ;; https://github.com/adobe-type-tools/afdko/issues/1678
+                 "not test_hashmap_no_version"
+                 "not test_hashmap_old_version")
+               " and "))
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'copy-font-data