summary refs log tree commit diff
path: root/gnu/packages/fpga.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-24 22:07:10 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-26 02:17:02 +0200
commit99f6ef9ab4b508e5081b5bf6e031054a7e04cec1 (patch)
tree95efc3697790ceb0cdaf01072fe3347931aaa76a /gnu/packages/fpga.scm
parentfbe4a5a2cb9972ce16ecbede7dd3be8d69029ace (diff)
downloadguix-99f6ef9ab4b508e5081b5bf6e031054a7e04cec1.tar.gz
gnu: yosys: Return #t from all phases.
* gnu/packages/fpga.scm (yosys)[arguments]: Substitute INVOKE for
SYSTEM*.
Diffstat (limited to 'gnu/packages/fpga.scm')
-rw-r--r--gnu/packages/fpga.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 0a5568a016..5c461f9861 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -152,7 +152,7 @@ For synthesis, the compiler generates netlists in the desired format.")
              #t))
          (replace 'configure
            (lambda* (#:key inputs (make-flags '()) #:allow-other-keys)
-             (zero? (apply system* "make" "config-gcc" make-flags))))
+             (apply invoke "make" "config-gcc" make-flags)))
          (add-after 'configure 'prepare-abc
            (lambda* (#:key inputs #:allow-other-keys)
              (let* ((sourceabc (assoc-ref inputs "abc"))
@@ -163,7 +163,7 @@ For synthesis, the compiler generates netlists in the desired format.")
                      (lambda (port)
                        (format port ".PHONY: all\nall:\n\tcp -f abc abc-default\n")))
                    (copy-file source "abc/abc")
-                   (zero? (system* "chmod" "+w" "abc/abc")))))
+                   (invoke "chmod" "+w" "abc/abc"))))
           (add-before 'check 'fix-iverilog-references
              (lambda* (#:key inputs native-inputs #:allow-other-keys)
                (let* ((xinputs (or native-inputs inputs))