summary refs log tree commit diff
path: root/gnu/packages/fpga.scm
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2022-12-22 12:09:52 -0500
committerLudovic Courtès <ludo@gnu.org>2022-12-27 23:53:41 +0100
commitc10238966ef936c294cdfe513c2d9fef7bb0671f (patch)
tree619a35d99fb690d49344165a4446088ed46052b5 /gnu/packages/fpga.scm
parente4f39ace86412f0c7cad999778b796abc13b1689 (diff)
downloadguix-c10238966ef936c294cdfe513c2d9fef7bb0671f.tar.gz
gnu: abc: Convey license information.
* gnu/packages/fpga.scm (abc)[arguments]: Add #:license-file-regexp so license
information is included in package output.
[license]: Specify URI of actual package license.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/fpga.scm')
-rw-r--r--gnu/packages/fpga.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index b2b3b63672..8784ba9c12 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -84,7 +84,8 @@
     (inputs
      (list readline))
     (arguments
-     `(#:tests? #f ; no check target
+     `(#:license-file-regexp "copyright.txt"
+       #:tests? #f ; no check target
        #:phases
        (modify-phases %standard-phases
          (delete 'configure)
@@ -98,7 +99,8 @@
     (description "ABC is a program for sequential logic synthesis and
 formal verification.")
     (license
-      (license:non-copyleft "https://fedoraproject.org/wiki/Licensing:MIT#Modern_Variants")))))
+     (license:non-copyleft
+      "https://people.eecs.berkeley.edu/~alanmi/abc/copyright.htm")))))
 
 (define-public iverilog
   (package