summary refs log tree commit diff
path: root/gnu/packages/fpga.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-10-05 14:11:05 -0500
committerLudovic Courtès <ludo@gnu.org>2022-10-11 16:05:32 +0200
commitf8529b9eec054cb015ff67e3068b06d5fa53fea1 (patch)
tree6b134ac60898d37a28301e7f9158ca6314afbdf6 /gnu/packages/fpga.scm
parent49ed67692d9ef9e7f262c264a5be10620ae695eb (diff)
downloadguix-f8529b9eec054cb015ff67e3068b06d5fa53fea1.tar.gz
gnu: gtkwave: Update to 3.3.113.
* gnu/packages/fpga.scm (gtkwave): Update to 3.3.113.
[inputs]: Use new style.
[arguments]: Use gexp.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/fpga.scm')
-rw-r--r--gnu/packages/fpga.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 11c56477a8..082b0c08ed 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -6,6 +6,7 @@
 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 Andrew Miloradovsky <andrew@interpretmath.pw>
 ;;; Copyright © 2022 Christian Gelinek <cgelinek@radlogic.com.au>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -24,6 +25,7 @@
 
 (define-module (gnu packages fpga)
   #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix gexp)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
@@ -352,7 +354,7 @@ FOSS FPGA place and route tool.")
 (define-public gtkwave
   (package
     (name "gtkwave")
-    (version "3.3.111")
+    (version "3.3.113")
     (source
      (origin
        (method url-fetch)
@@ -362,23 +364,20 @@ FOSS FPGA place and route tool.")
                   (string-append "http://gtkwave.sourceforge.net/"
                                  "gtkwave-" version ".tar.gz")))
        (sha256
-        (base32 "15n2gv2hd7h23cci95ij7yr71fkxppb209sfdsmmngh3fik09rpn"))))
+        (base32 "1zqkfchmns5x90qxa8kg39bfhax3vxf1mrdz3lhyb9fz1gp4difn"))))
     (build-system gnu-build-system)
     (native-inputs
      (list gperf pkg-config))
     (inputs
-     `(("tcl" ,tcl)
-       ("tk" ,tk)
-       ("gtk+-2" ,gtk+-2)))
+     (list tcl tk gtk+-2))
     (arguments
-     `(#:configure-flags
-       (list (string-append "--with-tcl="
-                            (assoc-ref %build-inputs "tcl")
-                            "/lib")
-             (string-append "--with-tk="
-                            (assoc-ref %build-inputs "tk")
-                            "/lib"))))
-
+     (list #:configure-flags
+           #~(list (string-append "--with-tcl="
+                                  (assoc-ref %build-inputs "tcl")
+                                  "/lib")
+                   (string-append "--with-tk="
+                                  (assoc-ref %build-inputs "tk")
+                                  "/lib"))))
     (synopsis "Waveform viewer for FPGA simulator trace files")
     (description "This package is a waveform viewer for FPGA
 simulator trace files (@dfn{FST}).")