summary refs log tree commit diff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorDavid Hashe <david.hashe@dhashe.com>2015-07-15 23:15:45 -0500
committer宋文武 <iyzsong@gmail.com>2015-07-17 20:48:22 +0800
commit177b42552f0f1aa5c5e52f5e441a00eaac9def8e (patch)
treec699d6fc5a0d1f0db090210cb3022ea865b3acc0 /gnu/packages/freedesktop.scm
parentaa90f2cda7286788faac7ca3529f7fd92e28734e (diff)
downloadguix-177b42552f0f1aa5c5e52f5e441a00eaac9def8e.tar.gz
gnu: Add exempi.
* gnu/packages/freedesktop.scm (exempi): New variable.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 5cdb4568c5..996b178234 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2015 Andy Wingo <wingo@pobox.com>
 ;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -39,6 +40,8 @@
   #:use-module (gnu packages glib)                ;intltool
   #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xorg)
+  #:use-module (gnu packages boost)
+  #:use-module (gnu packages compression)
   #:use-module (gnu packages doxygen)
   #:use-module (gnu packages libffi))
 
@@ -265,3 +268,30 @@ display server running on Linux kernel modesetting and evdev input devices, an X
 application, or a wayland client itself.  The clients can be traditional
 applications, X servers (rootless or fullscreen) or other display servers.")
     (license license:x11)))
+
+(define-public exempi
+  (package
+    (name "exempi")
+    (version "2.2.2")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "http://libopenraw.freedesktop.org/download/"
+                   name "-" version ".tar.bz2"))
+             (sha256
+              (base32
+               "01vcd1mfn2s0iiq2cjyzgvnxx6kcq9cwra1iipijhs0vwvjx0yhf"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags (list (string-append "--with-boost="
+                               (assoc-ref %build-inputs "boost")))))
+    (native-inputs
+     `(("boost" ,boost))) ; tests
+    (inputs
+     `(("expat" ,expat)
+       ("zlib" ,zlib)))
+    (home-page "https://wiki.freedesktop.org/libopenraw/Exempi")
+    (synopsis "XMP metadata handling library")
+    (description "Exempi is an implementation of the Extensible Metadata
+Platform (XMP), which enables embedding metadata in PDF and image formats.")
+    (license license:bsd-3)))