summary refs log tree commit diff
path: root/gnu/packages/ftp.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-10-21 18:33:09 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2016-10-23 16:33:04 +0200
commitbdc74f07c366e64891693be7c4aa2b8d779c36e9 (patch)
treedcba46db59342a8daeae3c31d9330f660387e11a /gnu/packages/ftp.scm
parent5f5b57681cebad4f4ab6b45c8da959ad349d0644 (diff)
downloadguix-bdc74f07c366e64891693be7c4aa2b8d779c36e9.tar.gz
gnu: weex: Use ‘modify-phases’.
* gnu/packages/ftp.scm (weex): Use the ‘modify-phases’ syntax.
Diffstat (limited to 'gnu/packages/ftp.scm')
-rw-r--r--gnu/packages/ftp.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/ftp.scm b/gnu/packages/ftp.scm
index e1e6191d03..a11265532a 100644
--- a/gnu/packages/ftp.scm
+++ b/gnu/packages/ftp.scm
@@ -139,18 +139,18 @@ FTP browser, as well as non-interactive commands such as 'ncftpput' and
         (patches (search-patches "weex-vacopy.patch"))))
     (build-system gnu-build-system)
     (arguments
-      `(#:phases
-        (alist-replace 'configure
-          ;; configure does not work followed by both "SHELL=..." and
-          ;; "CONFIG_SHELL=..."; set environment variables instead
-          (lambda* (#:key outputs #:allow-other-keys)
-            (let* ((out (assoc-ref outputs "out"))
-                  (bash (which "bash")))
-              (setenv "SHELL" bash)
-              (setenv "CONFIG_SHELL" bash)
-              (zero? (system* bash "./configure"
-                              (string-append "--prefix=" out)))))
-          %standard-phases)))
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+                  ;; configure does not work followed by both "SHELL=..." and
+                  ;; "CONFIG_SHELL=..."; set environment variables instead
+                  (lambda* (#:key outputs #:allow-other-keys)
+                    (let* ((out (assoc-ref outputs "out"))
+                           (bash (which "bash")))
+                      (setenv "SHELL" bash)
+                      (setenv "CONFIG_SHELL" bash)
+                      (zero? (system* bash "./configure"
+                                      (string-append "--prefix=" out)))))))))
     (home-page "http://weex.sourceforge.net/")
     (synopsis "Non-interactive client for FTP synchronization")
     (description