summary refs log tree commit diff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-08 22:00:57 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-08 22:05:09 +0100
commit8798f940ad0492da140ff170b18799029306c7a8 (patch)
tree5f56f8714e2effdbb5ec0b335a9fe7362e3a6431 /gnu/packages/game-development.scm
parent24e87f64cfaf6fb5c3ac1fda9ac67c277c610c5e (diff)
downloadguix-8798f940ad0492da140ff170b18799029306c7a8.tar.gz
Revert update to Renpy 8.2.
This reverts commits 9d53c236a69786508197c75d42923e8891c9212d,
2bfe8e95ef7d83961b80b6bacedd2c8c84e056bc, and
08ed3ec64ecd571d92d497b2493f5c0225102c99 as a temporary fix to
<https://bugs.gnu.org/68982>.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 5335166d19..78fd42518e 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1344,7 +1344,7 @@ and multimedia programs in the Python language.")
 
 (define-public python-pygame-sdl2
   (let ((real-version "2.1.0")
-        (renpy-version "8.2.0"))
+        (renpy-version "8.1.3"))
     (package
       (inherit python-pygame)
       (name "python-pygame-sdl2")
@@ -1354,7 +1354,7 @@ and multimedia programs in the Python language.")
          (method url-fetch)
          (uri (string-append "https://www.renpy.org/dl/" renpy-version
                              "/pygame_sdl2-" version ".tar.gz"))
-         (sha256 (base32 "17mc39c7ha83kzv2wmq61a15mn6p8wh2y33ixhf5sb4bvyr48mhy"))
+         (sha256 (base32 "0qlprs9n3w254ilizqzvr6s01zx72gh7an0bgwxsq4hm22qypdws"))
          (modules '((guix build utils)))
          (snippet
           '(begin
@@ -1395,7 +1395,7 @@ developed mainly for Ren'py.")
 (define-public python-renpy
   (package
     (name "python-renpy")
-    (version "8.2.0")
+    (version "8.1.3")
     (source
      (origin
        (method url-fetch)
@@ -1403,7 +1403,7 @@ developed mainly for Ren'py.")
                            "/renpy-" version "-source.tar.bz2"))
        (sha256
         (base32
-         "02v54qqjjigfqhdr50kzhkdvplk56bvprq65jl57kcs1qhvlf5s9"))
+         "1g6fz5dxp7yxhgv6q4brzf5hpfqq3l1g3dfv3fsiwwn6mj0b01z2"))
        (modules '((guix build utils)))
        (snippet
         #~(begin