summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-11-03 14:25:30 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-03 14:27:51 +0200
commit075df3d3e2f86ad2548075969b34402a3c40ec42 (patch)
tree303b422a84ce5ee1fccff610eaf83b20919e8b87 /gnu/packages/games.scm
parentaba40a6b7fdce56fe439668b3152ae4d4ddd1551 (diff)
parentb2721c3656e0ddf76dcccccfbacaaa309d2f47fe (diff)
downloadguix-075df3d3e2f86ad2548075969b34402a3c40ec42.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm63
1 files changed, 61 insertions, 2 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 34051b8fda..521bfcca2c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7502,7 +7502,7 @@ Strife, Chex Quest, and fan-created games like Harmony, Hacx and Freedoom.")
 (define-public odamex
   (package
     (name "odamex")
-    (version "0.9.3")
+    (version "0.9.5")
     (source
      (origin
        (method url-fetch)
@@ -7510,7 +7510,7 @@ Strife, Chex Quest, and fan-created games like Harmony, Hacx and Freedoom.")
              "mirror://sourceforge/odamex/Odamex/" version "/"
              "odamex-src-" version ".tar.bz2"))
        (sha256
-        (base32 "0vmw9ijb6n4wrxjxixakn7l6a6carnvs9wbbzb4vcq1brbzyrb0p"))))
+        (base32 "1x0c9vnwn336inkfamh4na8xjyfjmzfxfn49j4snqymkypjqw6jq"))))
     (build-system cmake-build-system)
     (arguments `(#:tests? #f))          ; no tests
     (native-inputs
@@ -8022,6 +8022,65 @@ ncurses for text display.")
     (home-page "http://frotz.sourceforge.net")
     (license license:gpl2+)))
 
+(define-public naev
+  (package
+    (name "naev")
+    (version "0.8.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/naev/naev")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "02rk2fv2nhx5xsi0cariisamab3dpncwps4q3i3ki0y27xpwxzfx"))))
+    (build-system meson-build-system)
+    (arguments
+     ;; XXX: Do not add debugging symbols, which cause the build to fail.
+     `(#:configure-flags (list "--buildtype=release")
+       #:tests? #f))          ;sole test fails with a missing "/dev/dri" error
+    (native-inputs
+     `(("gettext" ,gettext-minimal)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("freetype" ,freetype)
+       ("glpk" ,glpk)
+       ("libpng" ,libpng)
+       ("libvorbis" ,libvorbis)
+       ("libwebp" ,libwebp)
+       ("libxml2" ,libxml2)
+       ("luajit" ,luajit)
+       ("openal" ,openal)
+       ("openblas" ,openblas)
+       ("physfs" ,physfs)
+       ("sdl" ,(sdl-union (list sdl2 sdl2-image sdl2-mixer)))
+       ("suitesparse" ,suitesparse)))
+    (home-page "https://naev.org/")
+    (synopsis "Game about space exploration, trade and combat")
+    (description
+     "Naev is a 2d action/rpg space game that combines elements from
+the action, RPG and simulation genres.  You pilot a spaceship from
+a top-down perspective, and are more or less free to do what you want.
+As the genre name implies, you’re able to trade and engage in combat
+at will.  Beyond that, there’s an ever-growing number of story-line
+missions, equipment, and ships; even the galaxy itself grows larger
+with each release.  For the literacy-inclined, there are large amounts
+of lore accompanying everything from planets to equipment.")
+    (license (list license:gpl3
+                   license:public-domain
+                   license:expat        ;edtaa3func.c
+                   license:bsd-2        ;distance_field.c
+                   license:bsd-3        ;perlin.c
+                   ;; Assets.
+                   license:silofl1.1
+                   license:gpl2+
+                   license:cc0
+                   license:cc-by3.0
+                   license:cc-by-sa3.0
+                   license:cc-by4.0
+                   license:cc-by-sa4.0))))
+
 (define-public frotz-dumb-terminal
   (package
     (name "frotz-dumb-terminal")