summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-07-28 20:36:17 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-07-28 21:24:12 +0200
commit0a00d157e69bc5a514b1a46791c7e8727a2d1855 (patch)
tree9582b14c139c7cebe00d1198a15d71d44ff1182e /gnu/packages/games.scm
parent6fba1f4ded933134afb9ef1d0c03848ce6cabceb (diff)
downloadguix-0a00d157e69bc5a514b1a46791c7e8727a2d1855.tar.gz
gnu: freeorion: Update to 0.4.10.
* gnu/packages/games.scm (freeorion): Update to 0.4.10.
[inputs]: Use Python 3 and default boost.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f7753352d6..26c2c7d231 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9436,15 +9436,15 @@ win.")
 (define-public freeorion
   (package
     (name "freeorion")
-    (version "0.4.9")
+    (version "0.4.10")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/freeorion/freeorion/releases/"
                            "download/v" version "/FreeOrion_v" version
-                           "_2020-02-02.db53471_Source.tar.gz"))
+                           "_2020-07-10.f3d403e_Source.tar.gz"))
        (sha256
-        (base32 "1qfnqkysagh8dw26plk229qh17mv4prjxs6qhfyczrmrrakb72an"))
+        (base32 "12xspixrkx6mmmsdqjha0hg02r4y73pk229l0wjq9s0yp8nb8ap7"))
        (modules '((guix build utils)))
        (snippet
         '(begin
@@ -9466,7 +9466,7 @@ win.")
                   (string-append "\"" roboto-dir "Roboto-" type ".ttf\");")))
                #t))))))
     (inputs
-     `(("boost" ,boost-with-python2)
+     `(("boost" ,boost)
        ("boost_signals" ,boost-signals2)
        ("font-dejavu" ,font-dejavu)
        ("font-roboto" ,font-google-roboto)
@@ -9477,7 +9477,7 @@ win.")
        ("libpng" ,libpng)
        ("libvorbis" ,libvorbis)
        ("openal" ,openal)
-       ("python2" ,python-2.7)
+       ("python" ,python)
        ("sdl2" ,sdl2)
        ("zlib" ,zlib)))
     (home-page "https://www.freeorion.org/index.php/Main_Page")