summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorJesse Gibbons <jgibbons2357+guix@gmail.com>2020-08-26 21:38:24 -0600
committerLudovic Courtès <ludo@gnu.org>2020-09-25 19:05:08 +0200
commit0fa3d89fbce36d82e4e4ae9da2753425594e8aa2 (patch)
tree16f4eba4647fab5cebb0877b01b6f257f1de8c61 /gnu/packages/games.scm
parent4423cadc9a89ac947fee87ed493f0b82327bae40 (diff)
downloadguix-0fa3d89fbce36d82e4e4ae9da2753425594e8aa2.tar.gz
gnu: freedink: Make "freedink-engine" and "freedink-data" public.
* gnu/packages/games.scm: (freedink-engine): Make public.
[arguments]: Add 'delete-freedinkedit-desktop' phase.
(freedink-data): Make public.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index b819cd104f..a90e708ab3 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2726,7 +2726,7 @@ interface or via an external visual interface such as GNU XBoard.")
                   (ftp-directory . "/chess")))
     (license license:gpl3+)))
 
-(define freedink-engine
+(define-public freedink-engine
   (package
     (name "freedink-engine")
     (version "109.6")
@@ -2756,7 +2756,16 @@ interface or via an external visual interface such as GNU XBoard.")
 	     (invoke "autoreconf")
 	     ;; Build fails when autom4te.cache exists.
 	     (delete-file-recursively "autom4te.cache")
-             #t)))))
+             #t))
+         (add-after 'install 'delete-freedinkedit-desktop
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+             ;; freedinkedit does not know where to find freedink data
+             ;; freedink data is read-only, so it cannot be edited anyway.
+             ;; TODO: fix freedink.desktop
+             (delete-file-recursively (string-append
+                            out "/share/applications"))
+             #t))))))
     (native-inputs `(("autoconf" ,autoconf)
                      ("automake" ,automake)
                      ("cxxtest" ,cxxtest)
@@ -2778,7 +2787,7 @@ game data files but it also supports user-produced game mods or \"D-Mods\".
 To that extent, it also includes a front-end for managing all of your D-Mods.")
     (license license:gpl3+)))
 
-(define freedink-data
+(define-public freedink-data
   (package
     (name "freedink-data")
     (version "1.08.20190120")