summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-03 18:18:54 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-03 18:18:54 +0200
commit18caa6f528b09d63ac26ba53f78e4c35fed5b317 (patch)
tree411f4465c1de0b5c87580c26550b570f9240712c /gnu/packages/games.scm
parentba66eec741a9fbddd74eb7fc54d2c53888ace5b7 (diff)
downloadguix-18caa6f528b09d63ac26ba53f78e4c35fed5b317.tar.gz
gnu: hyperrogue: Fix build failure.
* gnu/packages/games.scm (hyperrogue)[arguments]: Do not assume CPATH is set.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 7555a0d800..f0f1886952 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4226,7 +4226,7 @@ throwing people around in pseudo-randomly generated buildings.")
          (add-after 'set-paths 'set-sdl-paths
            (lambda* (#:key inputs #:allow-other-keys)
              (setenv "CPATH"
-                     (string-append (getenv "CPATH") ":"
+                     (string-append (or (getenv "CPATH") "") ":"
                                     (assoc-ref inputs "sdl-union")
                                     "/include/SDL"))))
          (replace 'configure