summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-10-23 11:44:04 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-10-23 11:44:17 +0300
commit1ee3079d780d2a9c5bd27980922f6fc7b239a21a (patch)
tree587a65e4f8faf657476ad4bf7022eef9f59b431f /gnu/packages/games.scm
parent3bf94bc8bcbc7cf259eaddc3c19c82fd34f20c10 (diff)
downloadguix-1ee3079d780d2a9c5bd27980922f6fc7b239a21a.tar.gz
gnu: cowsay: Run tests after install.
* gnu/packages/games.scm (cowsay)[arguments]: Delete 'check phase, add
custom 'check phase after install.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 6709f02923..61eed39ef0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -267,7 +267,8 @@ the others like yourself, that want what you have.")
            (lambda* (#:key outputs #:allow-other-keys)
              (zero? (system* "sh" "install.sh"
                              (assoc-ref outputs "out")))))
-         (replace 'check
+         (delete 'check)
+         (add-after 'install 'check
            (lambda* (#:key outputs #:allow-other-keys)
              (zero? (system* (string-append (assoc-ref outputs "out")
                                             "/bin/cowsay")