summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-11-03 22:01:23 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-04 00:11:08 +0200
commit230b34cb5c88bcfda155094fde85a0a125f490f2 (patch)
tree875742ea88cc49b1b3ffe4e3d3bf8a16caa4b042 /gnu/packages/games.scm
parent3a5b1cc32a4f9dd1128f373c087d37aad95ed309 (diff)
downloadguix-230b34cb5c88bcfda155094fde85a0a125f490f2.tar.gz
gnu: simgear: Honor #:tests? flag.
* gnu/packages/games.scm (simgear)[arguments]: Adjust custom 'check
phase to honor the #:tests? flag.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f601e96035..b1de90cf24 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9275,9 +9275,10 @@ levels to unlock.")
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _
-             ;; Skip tests that require internet access.
-             (invoke "ctest" "-E" "(http|dns)"))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               ;; Skip tests that require internet access.
+               (invoke "ctest" "-E" "(http|dns)")))))))
     (inputs
      `(("boost" ,boost-for-mysql)       ; fails with 1.69
        ("curl" ,curl)