summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-10 14:39:59 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-10 15:06:50 +0000
commit54592df80d915a1841908daaa269fc0c82bf6926 (patch)
tree53e090c041461bc07833bc5a216c49940f8cba26 /gnu/packages/games.scm
parent6aefab6c0c5e9656572ce0ad8d9d41e27cb17071 (diff)
downloadguix-54592df80d915a1841908daaa269fc0c82bf6926.tar.gz
gnu: odamex: Unbundle some libraries.
* gnu/packages/games.scm (odamex) [snippet]: Remove some bundled
libraries which may be replaced by inputs.
[arguments] <#:configure-flags>: Add options to build client, master and
server. Do not use internal libs explicitly.
[native-inputs]: Add pkg-config.

Change-Id: I1974febb2f5f37d963ecb5b663d17a330ba23129
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm24
1 files changed, 21 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 260fd08cfc..95f55a7e48 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8104,11 +8104,29 @@ Strife, Chex Quest, and fan-created games like Harmony, Hacx and Freedoom.")
              "mirror://sourceforge/odamex/Odamex/" version "/"
              "odamex-src-" version ".tar.xz"))
        (sha256
-        (base32 "1isrmki18471yry48mmm7lxzp1kiqma9cc7fx38cvpm2mpgfyvzk"))))
+        (base32 "1isrmki18471yry48mmm7lxzp1kiqma9cc7fx38cvpm2mpgfyvzk"))
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           ;; XXX: Unbundle more, they are not replaced by the ones provided
+           ;; in inputs: fltk, jsoncpp, miniupnp, protobuf.
+           ;;
+           ;; Remove some bundled libraries.
+           (with-directory-excursion "libraries"
+             (for-each delete-file-recursively
+                       '("curl" "libpng" "portmidi" "zlib")))))))
     (build-system cmake-build-system)
-    (arguments `(#:tests? #f))          ; no tests
+    (arguments
+     (list
+      #:tests? #f ; no tests
+      #:configure-flags
+      #~(list "-DBUILD_CLIENT=1"
+              "-DBUILD_MASTER=1"
+              "-DBUILD_SERVER=1"
+              "-DUSE_INTERNAL_LIBS=0"
+              "-DUSE_INTERNAL_MINIUPNP=0")))
     (native-inputs
-     (list deutex))
+     (list deutex pkg-config))
     (inputs
      `(("alsa-lib" ,alsa-lib)
        ("curl" ,curl)