summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-04-18 20:57:15 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-04-18 20:57:15 +0300
commitdc9b1835d204e942ffb6bfc1939e204b1dad3aa2 (patch)
treee519191f6bffedcfbb7cbad48f03649a3dc56e5d /gnu/packages/games.scm
parent1a9af96b188368fb636eb2df7c6771c45a5b0a66 (diff)
downloadguix-dc9b1835d204e942ffb6bfc1939e204b1dad3aa2.tar.gz
gnu: chess: Set upstream name and ftp-directory.
* gnu/packages/games.scm (chess)[properties]: New field. Add
upstream-name and ftp-directory.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index b15d4eeb3a..181eab19b2 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -19,7 +19,7 @@
 ;;; Copyright © 2016 Albin Söderqvist <albin@fripost.org>
 ;;; Copyright © 2016, 2017, 2018, 2019 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
-;;; Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2016 Steve Webber <webber.sl@gmail.com>
 ;;; Copyright © 2017 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@hyperbola.info>
@@ -1970,6 +1970,8 @@ asynchronously and at a user-defined speed.")
     (description "GNU Chess is a chess engine.  It allows you to compete
 against the computer in a game of chess, either through the default terminal
 interface or via an external visual interface such as GNU XBoard.")
+    (properties '((upstream-name . "gnuchess")
+                  (ftp-directory . "/chess")))
     (license license:gpl3+)))
 
 (define freedink-engine