summary refs log tree commit diff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-09 22:35:33 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-09 23:29:20 +0100
commit4eb01e5442aa7bbaa880ae8e72bd5d27434855ef (patch)
tree2861126f25033783f548c291eb506cb536df2f30 /gnu/packages/gawk.scm
parentaa1e19477b2d78884fc500fef497cd6677604d9b (diff)
downloadguix-4eb01e5442aa7bbaa880ae8e72bd5d27434855ef.tar.gz
build-system/gnu: Patch /usr/bin/file in all 'configure' files.
* guix/build/utils.scm (patch-/usr/bin/file): New procedure.
* guix/build/gnu-build-system.scm (patch-usr-bin-file): Rewrite using
  it.  Patch all the files returned by 'find-files' that are executable.
* gnu/packages/gawk.scm (gawk)[arguments]: Remove use of 'substitute*'
  for 'extension/configure'.
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm10
1 files changed, 1 insertions, 9 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 74d0720567..e0d3f41ac2 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -55,14 +55,6 @@
                           '((substitute* "extension/Makefile.in"
                               (("^.*: check-for-shared-lib-support" match)
                                (string-append "### " match))))
-                          '())
-
-                    ;; XXX FIXME prerelease libtool fails on MIPS in the
-                    ;; absence of /usr/bin/file.
-                    ,@(if (string-prefix? "mips64" (or (%current-target-system)
-                                                       (%current-system)))
-                          '((substitute* "extension/configure"
-                              (("/usr/bin/file") (which "file"))))
                           '())))
 
                 (alist-cons-before