summary refs log tree commit diff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-26 14:50:14 +0200
committerMarius Bakke <marius@gnu.org>2022-06-26 22:58:33 +0200
commitda25a43f2dc582249f50d67119ea894c216db048 (patch)
tree6f6e97ab21f78f1cdfc950597ff8e8e83ab672f1 /gnu/packages/gawk.scm
parent003128f2f3e499b5064679a3ad4b63d911f3b777 (diff)
downloadguix-da25a43f2dc582249f50d67119ea894c216db048.tar.gz
gnu: gawk: Use G-expressions and remove labels.
* gnu/packages/gawk.scm (gawk)[arguments]: Convert to G-expression.  Use
SEARCH-INPUT-FILE instead of label.
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm51
1 files changed, 26 insertions, 25 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index add0c0a91b..55759f47ff 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -25,6 +25,7 @@
   #:use-module (gnu packages bash)
   #:use-module (gnu packages libsigsegv)
   #:use-module (guix packages)
+  #:use-module (guix gexp)
   #:use-module (guix download)
   #:use-module (guix build-system gnu))
 
@@ -40,36 +41,36 @@
              (base32 "18kybw47fb1sdagav7aj95r9pp09r5gm202y3ahvwjw9dqw2jxnq"))))
    (build-system gnu-build-system)
    (arguments
-    `(#:phases (modify-phases %standard-phases
-                 (add-before 'configure 'set-shell-file-name
-                   (lambda* (#:key inputs #:allow-other-keys)
-                     ;; Refer to the right shell.
-                     (let ((bash (assoc-ref inputs "bash")))
-                       (substitute* "io.c"
-                         (("/bin/sh")
-                          (string-append bash "/bin/sh")))
+    (list #:phases
+          #~(modify-phases %standard-phases
+              (add-before 'configure 'set-shell-file-name
+                (lambda* (#:key inputs #:allow-other-keys)
+                  ;; Refer to the right shell.
+                  (let ((/bin/sh (search-input-file inputs "bin/sh")))
+                    (substitute* "io.c"
+                      (("/bin/sh") /bin/sh))
 
-                       ;; When cross-compiling, remove dependencies on the
-                       ;; `check-for-shared-lib-support' target, which tries
-                       ;; to run the cross-built `gawk'.
-                       ,@(if (%current-target-system)
-                             '((substitute* "extension/Makefile.in"
+                    ;; When cross-compiling, remove dependencies on the
+                    ;; `check-for-shared-lib-support' target, which tries
+                    ;; to run the cross-built `gawk'.
+                    #$@(if (%current-target-system)
+                           '((substitute* "extension/Makefile.in"
                                  (("^.*: check-for-shared-lib-support" match)
                                   (string-append "### " match))))
-                             '()))))
+                           '()))))
 
-                 (add-before 'check 'adjust-test-infrastructure
-                   (lambda _
-                     ;; Remove dependency on 'more' (from util-linux), which
-                     ;; would needlessly complicate bootstrapping.
-                     (substitute* "test/Makefile"
-                       (("\\| more") ""))
+              (add-before 'check 'adjust-test-infrastructure
+                (lambda _
+                  ;; Remove dependency on 'more' (from util-linux), which
+                  ;; would needlessly complicate bootstrapping.
+                  (substitute* "test/Makefile"
+                    (("\\| more") ""))
 
-                     ;; Adjust the shebang in that file since it is then diff'd
-                     ;; against the actual test output.
-                     (substitute* "test/watchpoint1.ok"
-                       (("#! /usr/bin/gawk")
-                        (string-append "#!" (which "gawk")))))))))
+                  ;; Adjust the shebang in that file since it is then diff'd
+                  ;; against the actual test output.
+                  (substitute* "test/watchpoint1.ok"
+                    (("#! /usr/bin/gawk")
+                     (string-append "#!" (which "gawk")))))))))
 
    (inputs (list libsigsegv
                  ;; Use the full-fledged Bash package, otherwise the test suite