summary refs log tree commit diff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-09-02 15:35:37 +0200
committerLudovic Courtès <ludo@gnu.org>2016-09-02 15:39:10 +0200
commite0649ff3c0db17a27999da36cf9bd9fead8df4c7 (patch)
tree89ea3fb90af2eb4e38fd053b89e938c862d93e6c /gnu/packages/gawk.scm
parent67fcf2358c2d592a471b7e5aae993aeb4cfc29a0 (diff)
downloadguix-e0649ff3c0db17a27999da36cf9bd9fead8df4c7.tar.gz
gnu: gawk: Update to 4.1.4.
* gnu/packages/gawk.scm (gawk): Update to 4.1.4.
[source]: Remove 'patches'.
[arguments]: Add 'adjust-test-infrastructure' phase.
* gnu/packages/patches/gawk-fts-test.patch: Remove.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm22
1 files changed, 18 insertions, 4 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index c6d322b708..9852f760e0 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -29,14 +29,13 @@
 (define-public gawk
   (package
    (name "gawk")
-   (version "4.1.3")
+   (version "4.1.4")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/gawk/gawk-" version
                                 ".tar.xz"))
             (sha256
-             (base32 "09d6pmx6h3i2glafm0jd1v1iyrs03vcyv2rkz12jisii3vlmbkz3"))
-            (patches (search-patches "gawk-fts-test.patch"))))
+             (base32 "0rn2mmjxm767zliqzd67j7h2ncjn4j0321c60y9fy3grs3i89qak"))))
    (build-system gnu-build-system)
    (arguments
     `(#:parallel-tests? #f                ; test suite fails in parallel
@@ -59,7 +58,22 @@
                                (string-append "### " match))))
                           '())))
 
-                %standard-phases)))
+                (alist-cons-before
+                 'check 'adjust-test-infrastructure
+                 (lambda _
+                   ;; Remove dependency on 'more' (from util-linux), which
+                   ;; would needlessly complicate bootstrapping.
+                   (substitute* "test/Makefile"
+                     (("\\| more") ""))
+
+                   ;; Adjust the shebang in that file since it is then diff'd
+                   ;; against the actual test output.
+                   (substitute* "test/watchpoint1.ok"
+                     (("#! /usr/bin/gawk")
+                      (string-append "#!" (which "gawk"))))
+                   #t)
+
+                 %standard-phases))))
    (inputs `(("libsigsegv" ,libsigsegv)
 
              ,@(if (%current-target-system)