summary refs log tree commit diff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-03-14 09:37:11 +0100
committerLudovic Courtès <ludo@gnu.org>2022-03-14 23:32:26 +0100
commit15bb35d0c42e6f61c3ffc8e5e6e2d9b2d00a8902 (patch)
treef566ae51b97660921b46da4ca25d89baa570807f /gnu/packages/gcc.scm
parente86293d250add87121ec7c1f02f0367632c389d8 (diff)
downloadguix-15bb35d0c42e6f61c3ffc8e5e6e2d9b2d00a8902.tar.gz
gnu: gcc@11: Inherit supported micro-architectures from gcc@10.
Previously, gcc@11 would inherit the 'compiler-cpu-architectures'
property from gcc@8.

* gnu/packages/gcc.scm (gcc-11)[properties]: New field.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 1f89915ac8..e00ecd947b 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -665,7 +665,10 @@ It also includes runtime support libraries for these languages.")
             (patches (search-patches "gcc-9-strmov-store-file-names.patch"
                                      "gcc-5.0-libvtv-runpath.patch"))
             (modules '((guix build utils)))
-            (snippet gcc-canadian-cross-objdump-snippet)))))
+            (snippet gcc-canadian-cross-objdump-snippet)))
+
+   ;; TODO: Add newly supported micro-architectures.
+   (properties (package-properties gcc-10))))
 
 ;; Note: When changing the default gcc version, update
 ;;       the gcc-toolchain-* definitions.