summary refs log tree commit diff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2020-09-11 18:07:59 +0200
committerLudovic Courtès <ludo@gnu.org>2020-09-13 23:34:22 +0200
commit542c4707de98289e85b9be1b63d2f3d1a77f7c35 (patch)
tree3d90411771093b7abc28c4e0fceb8ba6a7fd11da /gnu/packages/gcc.scm
parenta4fe16ee41d64bfe9cb9402c29d11d974c235662 (diff)
downloadguix-542c4707de98289e85b9be1b63d2f3d1a77f7c35.tar.gz
gnu: gccgo: Reword synopsis and description.
Fixes <https://bugs.gnu.org/43303>.
Reported by Jeffrey Walton <noloader@gmail.com>.

* gnu/packages/gcc.scm: (gccgo-4.9): Add synopsis and description

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index c74477aed9..4d5aaa7070 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -773,7 +773,13 @@ misnomer.")))
 
 
 (define-public gccgo-4.9
-  (custom-gcc gcc-4.9 "gccgo" '("go")
+  (custom-gcc (package
+                (inherit gcc-4.9)
+                (synopsis "Go frontend to GCC")
+                (description
+                 "This package is part of the GNU Compiler Collection and
+provides the GNU compiler for the Go programming language."))
+              "gccgo" '("go")
               %generic-search-paths
               ;; Suppress the separate "lib" output, because otherwise the
               ;; "lib" and "out" outputs would refer to each other, creating