summary refs log tree commit diff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-01-02 10:33:02 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-01-03 23:06:43 +0200
commit7bbc708a4e5849158a6b688da0a0958b275f9eea (patch)
tree03c92f943a141b10e6a394aaa78eada89e65d68c /gnu/packages/gcc.scm
parent7a66b6873002e44aeb9bbf647fe75b21925cf3aa (diff)
downloadguix-7bbc708a4e5849158a6b688da0a0958b275f9eea.tar.gz
gnu: gcc@4.8: Fix building with glibc@2.26.
* gnu/packages/gcc.scm (gcc@4.8)[source]: Add snippet to adjust
linux-unwind.h to changes in glibc@2.26.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 8b0050d506..f7116bc914 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -363,7 +363,18 @@ Go.  It also includes runtime support libraries for these languages.")
                (base32
                 "08yggr18v373a1ihj0rg2vd6psnic42b518xcgp3r9k81xz1xyr2"))
               (patches (search-patches "gcc-arm-link-spec-fix.patch"
-                                       "gcc-fix-texi2pod.patch"))))
+                                       "gcc-fix-texi2pod.patch"))
+              (modules '((guix build utils)))
+              ;; This is required for building with glibc-2.26.
+              ;; https://gcc.gnu.org/bugzilla/show_bug.cgi?id=81712
+              (snippet
+               '(for-each
+                  (lambda (dir)
+                    (substitute* (string-append "libgcc/config/"
+                                                dir "/linux-unwind.h")
+                      (("struct ucontext") "ucontext_t")))
+                  '("aarch64" "alpha" "bfin" "i386" "m68k"
+                    "pa" "sh" "tilepro" "xtensa")))))
     (supported-systems %supported-systems)
     (inputs
      `(("isl" ,isl-0.11)