summary refs log tree commit diff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-05-07 09:28:55 +0100
committerChristopher Baines <mail@cbaines.net>2023-05-07 12:16:51 +0100
commitaad47b1b925262eb27ee1d4fcd19461deebb12e6 (patch)
treeaf049ad8c8f8cf0626eaf64ac0be042d3f555afa /gnu/packages/gcc.scm
parentfccb48d2cec6bcf47647c82914f31e2dff617f9c (diff)
downloadguix-aad47b1b925262eb27ee1d4fcd19461deebb12e6.tar.gz
Revert "gnu: gcc-11: Adapt patching for hurd to not use gexp's."
This reverts commit 08acdd0765b5f4fbfafa699a823ea7985d4d35a7.

This change is now unnecessary now that gcc-boot0 uses
gexps (a795a02a9d988be5a762886620f7bb6a95e7ffdb).

* gnu/packages/gcc.scm (gcc-11)[arguments]: Use gexp for modify-phases.
[native-inputs]: Remove.
* gnu/packages/commencement.scm (gcc-boot0)[native-inputs]: Remove.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm21
1 files changed, 9 insertions, 12 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index d1c79b8dc2..bdcc3f0508 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -715,25 +715,22 @@ It also includes runtime support libraries for these languages.")
             (snippet gcc-canadian-cross-objdump-snippet)))
    (arguments
     (substitute-keyword-arguments (package-arguments gcc-8)
-      ((#:phases phases '%standard-phases)
+      ((#:phases phases #~%standard-phases)
        (if (target-hurd?)
-           `(modify-phases ,phases
-              (add-after 'unpack 'patch-hurd-libpthread
-                (lambda _
-                  (invoke "patch" "--force" "-p1" "-i"
-                          (assoc-ref %build-inputs "hurd-patch")))))
+           #~(modify-phases #$phases
+               (add-after 'unpack 'patch-hurd-libpthread
+                 (lambda _
+                   (define patch
+                     #$(local-file
+                        (search-patch "gcc-11-libstdc++-hurd-libpthread.patch")))
+                   (invoke "patch" "--force" "-p1" "-i" patch))))
            phases))))
    (properties
     `((compiler-cpu-architectures
        ("aarch64" ,@%gcc-11-aarch64-micro-architectures)
        ("armhf" ,@%gcc-11-armhf-micro-architectures)
        ("x86_64" ,@%gcc-11-x86_64-micro-architectures))
-      ,@(package-properties gcc-8)))
-   (native-inputs
-    `(,@(if (target-hurd?)
-            `(("hurd-patch" ,(search-patch "gcc-11-libstdc++-hurd-libpthread.patch")))
-            '())
-      ,@(package-native-inputs gcc-8)))))
+      ,@(package-properties gcc-8)))))
 
 (define-public gcc-12
   (package