summary refs log tree commit diff
path: root/gnu/packages/gdb.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-27 10:01:09 +0200
committerMarius Bakke <marius@gnu.org>2020-06-27 10:01:09 +0200
commit361541d4a51b343694f9f14f150d3c6612490687 (patch)
tree509bb6e0241d22039a2e35be1f180ee5c8c41d83 /gnu/packages/gdb.scm
parent35691bf5dc69e4d482b31fab63e3bd73ffece755 (diff)
downloadguix-361541d4a51b343694f9f14f150d3c6612490687.tar.gz
gnu: gdb: Apply cross-build fix without changing the native variant.
Commit 76129cd3edb1eb62778344de0b1b44365f82ee06 accidentally changed the gdb
derivation, causing too many rebuilds for the 'master' branch.

* gnu/packages/gdb.scm (gdb-9.1)[arguments]: Only apply cross-build fix when
cross-compiling.
Diffstat (limited to 'gnu/packages/gdb.scm')
-rw-r--r--gnu/packages/gdb.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index 3a3792e3da..5c8ea0c62b 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -70,14 +70,20 @@
                      #t))
                   (add-after
                    'install 'remove-libs-already-in-binutils
-                   (lambda* (#:key inputs native-inputs outputs
+                   (lambda* (#:key inputs outputs
+                             ;; TODO: Inline the native-inputs addition and
+                             ;; below usage in the next rebuild cycle.
+                             ,@(if (%current-target-system)
+                                   '(native-inputs)
+                                   '())
                              #:allow-other-keys)
                      ;; Like Binutils, GDB installs libbfd, libopcodes, etc.
                      ;; However, this leads to collisions when both are
                      ;; installed, and really is none of its business,
                      ;; conceptually.  So remove them.
-                     (let* ((binutils (or (assoc-ref inputs "binutils")
-                                          (assoc-ref native-inputs "binutils")))
+                     (let* ((binutils ,@(if (%current-target-system)
+                                            '((assoc-ref native-inputs "binutils"))
+                                            '((assoc-ref inputs "binutils"))))
                             (out      (assoc-ref outputs "out"))
                             (files1   (with-directory-excursion binutils
                                         (append (find-files "lib")