summary refs log tree commit diff
path: root/gnu/packages/gdb.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-29 23:36:03 +0100
committerMarius Bakke <marius@gnu.org>2020-12-13 21:44:10 +0100
commit5b6b1608b24a58f2154ce5d642a9476296392c58 (patch)
tree8f605002cfb7ddc9b12e9c077d9fac84e9a429ca /gnu/packages/gdb.scm
parent18daba93d3fcec0e5fd9e54b6c4c7e5b979f1a6e (diff)
downloadguix-5b6b1608b24a58f2154ce5d642a9476296392c58.tar.gz
gnu: Remove gdb@9.
* gnu/packages/gdb.scm (gdb-9): Rename to ...
(gdb-10): ... this.  Update to 10.1.
[inputs]: Change from GUILE-2.0 to GUILE-3.0.
(gdb-8.2): Inherit from GDB-10.
[inputs]: Stick with GUILE-2.0.
(gdb-10): Remove variable.
(gdb): Point to GDB-10.
(gdb-minimal): Inherit from GDB.
Diffstat (limited to 'gnu/packages/gdb.scm')
-rw-r--r--gnu/packages/gdb.scm36
1 files changed, 12 insertions, 24 deletions
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index 79fc49f5ff..51b800d0d1 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -38,20 +38,20 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
+  #:use-module ((guix build utils) #:select (alist-replace))
   #:use-module (srfi srfi-1))
 
-(define-public gdb-9.2
+(define-public gdb-10
   (package
     (name "gdb")
-    (version "9.2")
+    (version "10.1")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/gdb/gdb-"
                                  version ".tar.xz"))
-             (patches (search-patches "gdb-hurd.patch"))
              (sha256
               (base32
-               "0mf5fn8v937qwnal4ykn3ji1y2sxk0fa1yfqi679hxmpg6pdf31n"))))
+               "1h32dckz1y8fnyxh22iyw8h3hnhxr79v1ng85px3ljn1xv71wbzq"))))
 
     (build-system gnu-build-system)
     (arguments
@@ -97,7 +97,7 @@
        ("gmp" ,gmp)
        ("readline" ,readline)
        ("ncurses" ,ncurses)
-       ("guile" ,guile-2.0)
+       ("guile" ,guile-3.0)
        ("python-wrapper" ,python-wrapper)
        ("source-highlight" ,source-highlight)
 
@@ -132,7 +132,7 @@ written in C, C++, Ada, Objective-C, Pascal and more.")
 ;; <https://bugs.gnu.org/37810>.
 (define-public gdb-8.2
   (package
-    (inherit gdb-9.2)
+    (inherit gdb-10)
     (version "8.2.1")
     (source (origin
               (method url-fetch)
@@ -140,31 +140,19 @@ written in C, C++, Ada, Objective-C, Pascal and more.")
                                   version ".tar.xz"))
               (sha256
                (base32
-                "00i27xqawjv282a07i73lp1l02n0a3ywzhykma75qg500wll6sha"))))))
+                "00i27xqawjv282a07i73lp1l02n0a3ywzhykma75qg500wll6sha"))))
+    (inputs
+     (alist-replace "guile" (list guile-2.0)
+                    (package-inputs gdb-10)))))
 
 (define-public gdb
   ;; This is the fixed version that packages depend on.  Update it rarely
   ;; enough to avoid massive rebuilds.
-  gdb-9.2)
-
-(define-public gdb-10
-  (package
-    (inherit gdb)
-    (version "10.1")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://gnu/gdb/gdb-"
-                                  version ".tar.xz"))
-              (sha256
-               (base32
-                "1h32dckz1y8fnyxh22iyw8h3hnhxr79v1ng85px3ljn1xv71wbzq"))))
-    (inputs
-     `(("guile" ,guile-3.0)
-       ,@(alist-delete "guile" (package-inputs gdb))))))
+  gdb-10)
 
 (define-public gdb-minimal
   (package/inherit
-   gdb-10
+   gdb
    (name "gdb-minimal")
    (inputs (fold alist-delete (package-inputs gdb)
                  '("libxml2" "ncurses" "python-wrapper" "source-highlight")))))