summary refs log tree commit diff
path: root/gnu/packages/gdb.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-13 17:56:28 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-14 18:34:01 +0100
commit759883ab5101443c0b0ece6bea6d02c60fb7287d (patch)
tree850660532e6b2ecd414bec08250d44de2e93cd8f /gnu/packages/gdb.scm
parent318c6a5aa932f1276b29c09ec5104fd9f0841b53 (diff)
downloadguix-759883ab5101443c0b0ece6bea6d02c60fb7287d.tar.gz
gnu: Remove gdb@8.3.
* gnu/packages/gdb.scm (gdb-8.3): Rename to ...
(gdb-9.1): ... this.  Update to 9.1.
[properties]: Remove.
[inputs]: Add SOURCE-HIGHLIGHT.
[arguments]: Add #:out-of-source?.
(gdb-8.2): Inherit from GDB-9.1.
(gdb): Set to GDB-9.1.
Diffstat (limited to 'gnu/packages/gdb.scm')
-rw-r--r--gnu/packages/gdb.scm35
1 files changed, 8 insertions, 27 deletions
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index 310bb6c320..01f93f6def 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -37,25 +37,24 @@
   #:use-module (guix build-system gnu)
   #:use-module (srfi srfi-1))
 
-(define-public gdb-8.3
+(define-public gdb-9.1
   (package
     (name "gdb")
-    (version "8.3.1")
+    (version "9.1")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/gdb/gdb-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "1i2pjwaafrlz7wqm40b4znr77ai32rjsxkpl2az38yyarpbv8m8y"))))
-
-    ;; Hide this package so that end users get 'gdb/next' below.
-    (properties '((hidden? . #t)))
+               "0dqp1p7w836iwijg1zb4a784n0j4pyjiw5v6h8fg5lpx6b40x7k9"))))
 
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f ; FIXME "make check" fails on single-processor systems.
 
+       #:out-of-source? #t
+
        #:modules ((srfi srfi-1)
                   ,@%gnu-build-system-modules)
 
@@ -96,6 +95,7 @@
        ("python" ,python)
        ("python-wrapper" ,python-wrapper)
        ("dejagnu" ,dejagnu)
+       ("source-highlight" ,source-highlight)
 
        ;; Allow use of XML-formatted syscall information.  This enables 'catch
        ;; syscall' and similar commands.
@@ -117,7 +117,7 @@ written in C, C++, Ada, Objective-C, Pascal and more.")
 ;; <https://bugs.gnu.org/37810>.
 (define-public gdb-8.2
   (package/inherit
-   gdb-8.3
+   gdb-9.1
    (version "8.2.1")
    (source (origin
              (method url-fetch)
@@ -127,26 +127,7 @@ written in C, C++, Ada, Objective-C, Pascal and more.")
               (base32
                "00i27xqawjv282a07i73lp1l02n0a3ywzhykma75qg500wll6sha"))))))
 
-;; The "next" version of GDB, to be merged with 'gdb' in the next rebuild cycle.
-(define-public gdb/next
-  (package/inherit
-   gdb-8.3
-   (version "9.1")
-   (source (origin
-             (method url-fetch)
-             (uri (string-append "mirror://gnu/gdb/gdb-" version ".tar.xz"))
-             (sha256
-              (base32
-               "0dqp1p7w836iwijg1zb4a784n0j4pyjiw5v6h8fg5lpx6b40x7k9"))))
-   (arguments
-    `(#:out-of-source? #t
-      ,@(package-arguments gdb-8.3)))
-   (inputs
-    `(("source-highlight" ,source-highlight)
-      ,@(package-inputs gdb-8.3)))
-   (properties (alist-delete 'hidden? (package-properties gdb-8.3)))))
-
 (define-public gdb
   ;; This is the fixed version that packages depend on.  Update it rarely
   ;; enough to avoid massive rebuilds.
-  gdb-8.3)
+  gdb-9.1)