summary refs log tree commit diff
path: root/gnu/packages/gdb.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-27 10:32:48 +0200
committerMarius Bakke <marius@gnu.org>2020-06-27 10:32:48 +0200
commitef2a3871fdebb5aa2b34fefbeec8d7be92e6097e (patch)
tree0f6c9e8245f7d89f4d4dad730e45d5da61685f7b /gnu/packages/gdb.scm
parent425fd7eb6a5f07eb9b854a5a29488e6f0b0acf3c (diff)
downloadguix-ef2a3871fdebb5aa2b34fefbeec8d7be92e6097e.tar.gz
gnu: GDB: Inline cross-compilation fix.
* gnu/packages/gdb.scm (gdb-9.1)[arguments]: Remove conditionals on
%CURRENT-TARGET-SYSTEM.
Diffstat (limited to 'gnu/packages/gdb.scm')
-rw-r--r--gnu/packages/gdb.scm12
1 files changed, 3 insertions, 9 deletions
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index 38e45b14e5..338b73aa58 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -70,20 +70,14 @@
                      #t))
                   (add-after
                    'install 'remove-libs-already-in-binutils
-                   (lambda* (#:key inputs outputs
-                             ;; TODO: Inline the native-inputs addition and
-                             ;; below usage in the next rebuild cycle.
-                             ,@(if (%current-target-system)
-                                   '(native-inputs)
-                                   '())
+                   (lambda* (#:key native-inputs inputs outputs
                              #:allow-other-keys)
                      ;; Like Binutils, GDB installs libbfd, libopcodes, etc.
                      ;; However, this leads to collisions when both are
                      ;; installed, and really is none of its business,
                      ;; conceptually.  So remove them.
-                     (let* ((binutils ,@(if (%current-target-system)
-                                            '((assoc-ref native-inputs "binutils"))
-                                            '((assoc-ref inputs "binutils"))))
+                     (let* ((binutils (or (assoc-ref inputs "binutils")
+                                          (assoc-ref native-inputs "binutils")))
                             (out      (assoc-ref outputs "out"))
                             (files1   (with-directory-excursion binutils
                                         (append (find-files "lib")