summary refs log tree commit diff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorHendursaga <hendursaga@aol.com>2023-09-17 15:39:35 -0400
committerGuillaume Le Vaillant <glv@posteo.net>2023-09-21 17:21:35 +0200
commit84442d04235a615984667363c0f9b6b91d1ed0bf (patch)
tree299c27abf4adff402e87a051975f6fe9870f29d6 /gnu/packages/geo.scm
parentbe9f749a29e30f78f81c3622d0668d19a472238a (diff)
downloadguix-84442d04235a615984667363c0f9b6b91d1ed0bf.tar.gz
gnu: libosmium: Update to 2.19.0.
* gnu/packages/geo.scm (libosmium): Update to 2.19.0.
  [inputs]: Replace proj with proj-7, the last version with PROJ API
  version 4 compatibility. Remove sparsehash and utfcpp.
  [native-inputs]: Add graphviz-minimal, to build documentation.

Reviewed-by: Bruno Victal <mirai@makinata.eu>
Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm48
1 files changed, 23 insertions, 25 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index d702046865..f41ef826fd 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -89,6 +89,7 @@
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gps)
   #:use-module (gnu packages graphics)
+  #:use-module (gnu packages graphviz)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages haskell-apps)
   #:use-module (gnu packages haskell-xyz)
@@ -1535,34 +1536,31 @@ visualizing and performing calculations with weather data.")
 (define-public libosmium
   (package
     (name "libosmium")
-    (version "2.18.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/osmcode/libosmium")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0fh57mpii1ksacwfx5rz213j896aklib53jbybld2i517q2mmxr0"))))
+    (version "2.19.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/osmcode/libosmium")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0d69xzd29hk846g049y2g668mr8kaf05f6a26s3qn6az062hxfa7"))))
     (build-system cmake-build-system)
-    (propagated-inputs
-     (list boost
-           bzip2
-           expat
-           gdal
-           geos
-           lz4
-           proj
-           protozero
-           sparsehash
-           utfcpp
-           zlib))
-    (native-inputs
-     (list doxygen))
+    (propagated-inputs (list boost
+                             bzip2
+                             expat
+                             gdal
+                             geos
+                             lz4
+                             proj-7
+                             protozero
+                             zlib))
+    (native-inputs (list doxygen graphviz-minimal))
     (home-page "https://osmcode.org/libosmium/")
     (synopsis "C++ library for working with OpenStreetMap data")
-    (description "Libosmium is a fast and flexible C++ library for working with
+    (description
+     "Libosmium is a fast and flexible C++ library for working with
 OpenStreetMap data.")
     (license license:boost1.0)))