summary refs log tree commit diff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-03-12 10:05:28 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-03-12 10:08:45 +0100
commitec73c90ee35a404b04b030b260c386011c0cbe94 (patch)
treecaefd8d0d991de3bc52b2073c0c7d6a35476caeb /gnu/packages/geo.scm
parent69b03ecd954a251a4ef7ef33dd95656114360272 (diff)
downloadguix-ec73c90ee35a404b04b030b260c386011c0cbe94.tar.gz
gnu: Add virtualpg.
* gnu/packages/geo.scm (virtualpg): New variable.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 05d177c3b1..7fd04f25c3 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1523,3 +1523,29 @@ input file (in @code{.osm} or @code{.osm.pbf} format).")
 tools supporting SpatiaLite.")
     (home-page "https://www.gaia-gis.it/fossil/spatialite-tools/index")
     (license license:gpl3+)))
+
+(define-public virtualpg
+  (package
+    (name "virtualpg")
+    (version "1.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://www.gaia-gis.it/gaia-sins/"
+                           "virtualpg-" version ".tar.gz"))
+       (sha256
+        (base32 "0kjipcd08vvn188xmwbs7sw41xcs06x47n2hbqshpjcr51mxbarp"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("postgresql" ,postgresql)
+       ("sqlite" ,sqlite)))
+    (synopsis "Allow SQLite/SpatiaLite to access PostgreSQL/PostGIS tables")
+    (description
+     "VirtualPG is a dynamic extension for the SQLite DBMS.  It implements
+the VirtualPostgres driver, allowing to directly exchange data between SQLite
+and PostgreSQL; if SpatiaLite is available even PostGIS geometries can be
+exchanged form one Spatial DBMS and the other.")
+    (home-page "https://www.gaia-gis.it/fossil/virtualpg/index")
+    (license (list license:gpl2+
+                   license:lgpl2.1+
+                   license:mpl1.1))))