summary refs log tree commit diff
path: root/gnu/packages/gforth.scm
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-17 20:23:34 +0000
committer宋文武 <iyzsong@gmail.com>2016-09-24 14:07:12 +0800
commit6fc48c2ee2475b004b090b9cb047d4c1ccbb5175 (patch)
tree5bd7c7d70a6e55125355c700d7fc6027643a6d86 /gnu/packages/gforth.scm
parent54021cd8c653f72fec5e487448a1b6aedb0c4fbe (diff)
downloadguix-6fc48c2ee2475b004b090b9cb047d4c1ccbb5175.tar.gz
gnu: Add gforth.
* gnu/packages/gforth.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.

Co-authored-by: 宋文武 <iyzsong@gmail.com>
Diffstat (limited to 'gnu/packages/gforth.scm')
-rw-r--r--gnu/packages/gforth.scm60
1 files changed, 60 insertions, 0 deletions
diff --git a/gnu/packages/gforth.scm b/gnu/packages/gforth.scm
new file mode 100644
index 0000000000..b2a67ce58c
--- /dev/null
+++ b/gnu/packages/gforth.scm
@@ -0,0 +1,60 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages gforth)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages m4))
+
+(define-public gforth
+  (package
+    (name "gforth")
+    (version "0.7.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnu/gforth/gforth-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "1c1bahc9ypmca8rv2dijiqbangm1d9av286904yw48ph7ciz4qig"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:parallel-build? #f             ; XXX: parallel build fails
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'install-gforth.el
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out           (assoc-ref outputs "out"))
+                    (emacs-sitedir (string-append
+                                    out "/share/emacs/site-lisp")))
+               ;; TODO: compile and autoload it.
+               (install-file "gforth.el" emacs-sitedir)
+               #t))))))
+    (native-inputs
+     `(("m4" ,m4)))
+    (synopsis "Forth interpreter")
+    (description
+     "Gforth is a fast and portable implementation of the ANSI Forth language.
+It includes an editing mode for Emacs and an interpreter featuring completion
+and history.  A generic virtual machine environment, vmgen, is also
+included.")
+    (home-page "https://www.gnu.org/software/gforth/")
+    (license license:gpl3+)))