summary refs log tree commit diff
path: root/gnu/packages/gimp.scm
diff options
context:
space:
mode:
authorRoman Scherer <roman@burningswell.com>2024-04-07 14:05:39 +0200
committerChristopher Baines <mail@cbaines.net>2024-04-17 17:55:53 +0100
commite1fefe84aa73d6d48ab43f7c613c7bc6d14d082f (patch)
tree316b4b2a3bb0ca70f03b517d06de0c8870f400da /gnu/packages/gimp.scm
parent46e54988057ece26b81cad20d33f39d383287e18 (diff)
downloadguix-e1fefe84aa73d6d48ab43f7c613c7bc6d14d082f.tar.gz
gnu: babl: Disable failing test on aarch64.
The float-to-8bit test fails on an Apple M1 (aarch64) with the following message:

 9/28 float-to-8bit                   FAIL            0.11s   exit status 1
>>> LD_LIBRARY_PATH=/tmp/guix-build-babl-0.1.108.drv-0/build/babl BABL_PATH=/tmp/guix-build-babl-0.1.108.drv-0/build/extensions MALLOC_PERTURB_=94 /tmp/guix-build-babl-0.1.108.drv-0/build/tests/float-to-8bit

stdout:
 float -> u8 1 failed #1[1]  got 76 expected 77
stderr:
        " 0x43b9f0 0x4390b0 1"  1541377792      BablFishPath
                cost:146.000000 error:0.000000000000
        "/tmp/guix-build-babl-0.1.108.drv-0/build/extensions/gggl.so 0: R'G'B'A float to R'G'B'A u8"    0       BablConversionLinear
                pixels:0
                error: 0.000000

* gnu/packages/gimp.scm (babl): Disable failing test on aarch64.

Change-Id: Icf2c2a9ea5986149902f741f96d1847d2403c1f4
Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/gimp.scm')
-rw-r--r--gnu/packages/gimp.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index b458a6397c..b2676e654e 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -193,8 +193,17 @@ of a larger interface.")
                 "0x8lxvnhfpssj84x47y3y06vsvhd5afb9jknw38c8ymbxafzxpi6"))))
     (build-system meson-build-system)
     (arguments
-     `(#:configure-flags
-       (list "-Dwith-docs=false")))
+     (list
+      #:configure-flags #~(list "-Dwith-docs=false")
+      #:phases
+      #~(modify-phases %standard-phases
+          #$@(if (target-aarch64?)
+                 #~((add-after 'unpack 'disable-failing-test
+                      (lambda _
+                        (substitute* "tests/meson.build"
+                          ;; float -> u8 1 failed #1[1]  got 76 expected 77
+                          (("'float-to-8bit',") "")))))
+                 '()))))
     (native-inputs
      (list gobject-introspection pkg-config vala))
     (propagated-inputs