summary refs log tree commit diff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-19 18:12:34 -0400
committerMark H Weaver <mhw@netris.org>2015-07-19 18:12:34 -0400
commit1b4e48d498a96d478baa1aae7d9c7ecdbd817d6f (patch)
tree4b650999e49a6f4d3dd116fab3f9ee8222247e07 /gnu/packages/gl.scm
parentaa27987f71cb8afa698ede551e20b1248f160113 (diff)
parent50c7a1e297bff0935674b4f30e854a8889becfdd (diff)
downloadguix-1b4e48d498a96d478baa1aae7d9c7ecdbd817d6f.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm39
1 files changed, 22 insertions, 17 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 9bb1134d39..e8003f88a3 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -130,7 +130,7 @@ the X-Consortium license.")
     (description
      "FTGL is a font rendering library for OpenGL applications.  Supported
 rendering modes are: Bitmaps, Anti-aliased pixmaps, Texture maps, Outlines,
-Polygon meshes, and Extruded polygon meshes")
+Polygon meshes, and Extruded polygon meshes.")
     (license l:x11)))
 
 (define-public s2tc
@@ -409,22 +409,27 @@ extension functionality is exposed in a single header file.")
               ("glu" ,glu)
               ("freeglut" ,freeglut)))
     (arguments
-     '(#:phases (alist-cons-before
-                 'build 'patch-dynamic-link
-                 (lambda* (#:key inputs outputs #:allow-other-keys)
-                   (define (dynamic-link-substitute file lib input)
-                     (substitute* file
-                       (("dynamic-link \"lib([a-zA-Z]+)\"" _ lib)
-                        (string-append "dynamic-link \""
-                                       (assoc-ref inputs input)
-                                       "/lib/lib" lib "\""))))
-                   ;; Replace dynamic-link calls for libGL, libGLU, and
-                   ;; libglut with absolute paths to the store.
-                   (dynamic-link-substitute "glx/runtime.scm" "GL" "mesa")
-                   (dynamic-link-substitute "glu/runtime.scm" "GLU" "glu")
-                   (dynamic-link-substitute "glut/runtime.scm" "glut"
-                                            "freeglut"))
-                 %standard-phases)))
+     '(#:phases (modify-phases %standard-phases
+                 (add-after 'configure 'patch-makefile
+                   (lambda _
+                     ;; Install compiled Guile files in the expected place.
+                     (substitute* '("Makefile")
+                       (("^godir = .*$")
+                        "godir = $(moddir)\n"))))
+                 (add-before 'build 'patch-dynamic-link
+                   (lambda* (#:key inputs outputs #:allow-other-keys)
+                     (define (dynamic-link-substitute file lib input)
+                       (substitute* file
+                         (("dynamic-link \"lib([a-zA-Z]+)\"" _ lib)
+                          (string-append "dynamic-link \""
+                                         (assoc-ref inputs input)
+                                         "/lib/lib" lib "\""))))
+                     ;; Replace dynamic-link calls for libGL, libGLU, and
+                     ;; libglut with absolute paths to the store.
+                     (dynamic-link-substitute "glx/runtime.scm" "GL" "mesa")
+                     (dynamic-link-substitute "glu/runtime.scm" "GLU" "glu")
+                     (dynamic-link-substitute "glut/runtime.scm" "glut"
+                                              "freeglut"))))))
     (home-page "http://gnu.org/s/guile-opengl")
     (synopsis "Guile binding for the OpenGL graphics API")
     (description