summary refs log tree commit diff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-12-28 21:13:26 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2023-12-28 21:13:26 -0500
commit92227248a616a9555200a48b1e4f1768a462556b (patch)
tree2e5bc472b5169742a4a5ffe5971ceb8be780970f /gnu/packages/gl.scm
parentbdab356332e391e09d0feafe0fcac9c52388a07d (diff)
parent7722da6fa5422c4fec69d6c8b9536c7d6fc3d326 (diff)
downloadguix-92227248a616a9555200a48b1e4f1768a462556b.tar.gz
Merge branch 'master' into mesa-updates
Change-Id: I16539f64df739453a83f8dfd962e04910a7d7ff5
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm43
1 files changed, 35 insertions, 8 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 8c5e61dfd2..ce99b33441 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -18,6 +18,7 @@
 ;;; Copyright © 2021, 2022, 2023 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -189,7 +190,7 @@ rendering modes are: Bitmaps, Anti-aliased pixmaps, Texture maps, Outlines,
 Polygon meshes, and Extruded polygon meshes.")
     (license license:x11)))
 
-(define-public glad
+(define-public glad-0.1
   (package
     (name "glad")
     (version "0.1.36")
@@ -208,19 +209,45 @@ Polygon meshes, and Extruded polygon meshes.")
          "0m55ya1zrmg6n2cljkajy80ilmi5sblln8742fm0k1sw9k7hzn8n"))))
     (build-system python-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'install-cmakelists.txt
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (share (string-append out "/share/" ,name)))
-               (install-file "CMakeLists.txt" share)))))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'install 'install-cmakelists.txt
+                 (lambda _
+                   (let ((share (string-append #$output "/share/"
+                                               #$(package-name this-package))))
+                     (install-file "CMakeLists.txt" share)))))))
     (home-page "https://github.com/Dav1dde/glad")
     (synopsis "Multi-language GL/GLES/EGL/GLX/WGL loader generator")
     (description "Glad uses the official Khronos XML specifications to
 generate a GL/GLES/EGL/GLX/WGL loader tailored for specific requirements.")
     (license license:expat)))
 
+(define-public glad
+  (package
+    (inherit glad-0.1)
+    (name "glad")
+    (version "2.0.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/Dav1dde/glad")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1pam6imhcmcyqrqi6wzzxprb23y8x6zdbvsjavnz26k72i9dbbja"))))
+    (build-system python-build-system)
+    (arguments
+     (substitute-keyword-arguments (package-arguments glad-0.1)
+       ((#:phases phases '%standard-phases)
+        #~(modify-phases #$phases
+            (replace 'install-cmakelists.txt
+              (lambda _
+                (let ((share (string-append #$output "/share/"
+                                            #$(package-name this-package))))
+                  (install-file "cmake/CMakeLists.txt" share))))))))
+    (propagated-inputs (list python-jinja2))))
+
 (define-public s2tc
   (package
     (name "s2tc")