summary refs log tree commit diff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-23 19:34:15 +0200
committerMarius Bakke <marius@gnu.org>2022-06-23 19:55:43 +0200
commitb40151ff4f1ad4230f64df408304ceb3b16ac2da (patch)
tree346fd087f26b8d13350ef1e4f54c45a3b41f9595 /gnu/packages/gl.scm
parentddc538ac3262756eacec650e0c5509cd4b4a7c7a (diff)
downloadguix-b40151ff4f1ad4230f64df408304ceb3b16ac2da.tar.gz
gnu: glu: Update to 9.0.2.
* gnu/packages/gl.scm (glu): Update to 9.0.2.
[source]: Switch to GIT-FETCH.
[native-inputs]: Add PKG-CONFIG, AUTOCONF, AUTOMAKE, and LIBTOOL.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm17
1 files changed, 12 insertions, 5 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index fcc110e6bf..66db679342 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -76,15 +76,22 @@
 (define-public glu
   (package
     (name "glu")
-    (version "9.0.1")
+    (version "9.0.2")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "ftp://ftp.freedesktop.org/pub/mesa/glu/glu-"
-                                  version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.freedesktop.org/mesa/glu")
+                    (commit (string-append "glu-" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1xqhk9bn10nbvffw3r4p4rjslwz1l7gaycc0x2pqkr2irp7q9x7n"))))
+                "1khxfidyglpx4yd8f3xvrj05ah823cz1ygcszhcaa4w7h9kd1lbr"))))
     (build-system gnu-build-system)
+    (native-inputs
+     (list pkg-config
+           autoconf
+           automake
+           libtool))
     (propagated-inputs
      (list mesa)) ; according to glu.pc
     (home-page "http://www.opengl.org/archives/resources/faq/technical/glu.htm")