summary refs log tree commit diff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-02 21:46:20 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 10:31:25 -0500
commit9c59623564fc9d74b04f2dea1130755215c608a2 (patch)
tree9c3784c422fdc573e7f834d5461826b47dc7887d /gnu/packages/glib.scm
parentc0443cffe872c1d08119f032156cd8fe3343f5bb (diff)
downloadguix-9c59623564fc9d74b04f2dea1130755215c608a2.tar.gz
Revert commits made to resolve a gdk-pixbuf+svg propagation issue.
Fixes <https://issues.guix.gnu.org/50957>.

This reverts the following commits:

 - 42231bc (gnu: cheese: Propagate gdk-pixbuf+svg rather than gdk-pixbuf)
 - ad6a950 (gnu: mutter: Propagate gdk-pixbuf+svg rather than gdk-pixbuf)
 - 5e02d1a (gnu: cogl: Propagate gdk-pixbuf+svg rather than gdk-pixbuf)
 - 5c467b2 (gnu: libgweather: Propagate gdk-pixbuf+svg rather than gdk-pixbuf)
 - 26487f6 (gnu: librsvg-next: Do not propagate gdk-pixbuf)
 - d891922 (gnu: librsvg: Do not propagate gdk-pixbuf)
 - 22476d3 (gnu: libgsf: Do not propagate gdk-pixbuf)
 - 099ca0e (gnu: libnotify: Propagate gdk-pixbuf+svg rather than gdk-pixbuf)
 - fb6a1ff (gnu: appstream-glib: Propagate gdk-pixbuf+svg rather than gdk-pixbuf)
 - 4fb525d (gnu: weasyprint: Propagate gdk-pixbuf+svg rather than gdk-pixbuf)

These commits were made to resolve a gdk-pixbuf loaders clash that could occur
in a profile when both gdk-pixbuf and gdk-pixbuf+svg were propagated.
Unfortunately, librsvg really needs to propagate gdk-pixbuf itself, which
would introduce a cycle.  Packages such as 'efl' were broken as a result of
not propagating gdk-pixbuf.

A more definitive fix will be proposed for core-updates, which includes a
profile hook to generate the gdk-pixbuf loaders.cache file, as well as a build
phase and search path specification, that should resolve the issue for good.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index ce9e3fcb41..3065ae8709 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -9,7 +9,7 @@
 ;;; Copyright © 2017 Petter <petter@mykolab.ch>
 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
-;;; Copyright © 2019, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
@@ -1179,7 +1179,7 @@ Some codes examples can be find at:
        ("pkg-config" ,pkg-config)))
     (propagated-inputs
      `(("gcab" ,gcab) ; for .pc file
-       ("gdk-pixbuf" ,gdk-pixbuf+svg) ; for .pc file
+       ("gdk-pixbuf" ,gdk-pixbuf) ; for .pc file
        ("libuuid" ,util-linux "lib"))) ; for .pc file
     (inputs
      `(("glib" ,glib)