summary refs log tree commit diff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-04-20 16:27:44 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-04-22 11:08:05 +0300
commita24562af52d2f318c9e17be73393ddb4bd9e347c (patch)
tree45fc6f0d2efa658e118f8cf03b1ed09c6e196af0 /gnu/packages/glib.scm
parent7fd5175693a430e365b928e69f8e6edee6c41cb3 (diff)
downloadguix-a24562af52d2f318c9e17be73393ddb4bd9e347c.tar.gz
gnu: glib: Disable failing test.
* gnu/packages/glib.scm (glib)[source]: Add patch.
[arguments]: Remove custom 'increase-test-timeout phase.
* gnu/packages/patches/glib-skip-failing-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index b288528c8a..7e49fca263 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -3,7 +3,7 @@
 ;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
 ;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2021 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
 ;;; Copyright © 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2017 Petter <petter@mykolab.ch>
@@ -187,7 +187,8 @@ shared NFS home directories.")
        (sha256
         (base32 "1sh3h6b734cxhdd1qlzvhxq6rc7k73dsisap5y3s419s9xc4ywv7"))
        (patches
-        (search-patches "glib-appinfo-watch.patch"))
+        (search-patches "glib-appinfo-watch.patch"
+                        "glib-skip-failing-test.patch"))
        (modules '((guix build utils)))
        (snippet
         '(begin
@@ -203,17 +204,6 @@ shared NFS home directories.")
        #:configure-flags '("-Dman=true")
        #:phases
        (modify-phases %standard-phases
-         ;; TODO: Remove the conditional in the next core-updates cycle.
-         ;; Needed to build glib on slower ARM nodes.
-         ,@(if (string-prefix? "arm" (%current-system))
-               `((add-after 'unpack 'increase-test-timeout
-                   (lambda _
-                     (substitute* "meson.build"
-                       (("test_timeout = 60")
-                        "test_timeout = 90")
-                       (("test_timeout_slow = 120")
-                        "test_timeout_slow = 180")))))
-               '())
          (add-after 'unpack 'disable-failing-tests
            (lambda _
              (with-directory-excursion "glib/tests"