summary refs log tree commit diff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-05-06 23:10:11 +0200
committerLudovic Courtès <ludo@gnu.org>2014-05-06 23:10:11 +0200
commitce2df078d7b8e8d44b831270421513bd04429866 (patch)
tree858fa7ef7b1d304096d9329b9f049a72c1df183c /gnu/packages/glib.scm
parent141aed808701351685de9d92532392384d730b37 (diff)
downloadguix-ce2df078d7b8e8d44b831270421513bd04429866.tar.gz
gnu: Make $XDG_DATA_DIRS a search path variable for GLib.
* gnu/packages/glib.scm (glib): Add 'native-search-paths' and
  'search-paths' fields.
* gnu/packages/gnome.scm (libpeas): Remove 'arguments' field.
  (librsvg)[arguments]: Remove #:modules and #:imported-modules.
  Remove settings of INTROSPECTION_SCANNER_ARGS and
  INTROSPECTION_COMPILER_ARGS in makefiles.
* gnu/packages/gtk.scm (gtk+): Likewise.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 49ffaa8f6e..77f21f95ce 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -160,6 +160,17 @@ shared NFS home directories.")
       ;; In 'gio/tests', 'gdbus-test-codegen-generated.h' is #included in a
       ;; file that gets compiled possibly before it has been fully generated.
       #:parallel-tests? #f))
+
+   (native-search-paths
+    ;; This variable is not really "owned" by GLib, but several related
+    ;; packages refer to it: gobject-introspection's tools use it as a search
+    ;; path for .gir files, and it's also a search path for schemas produced
+    ;; by 'glib-compile-schemas'.
+    (list (search-path-specification
+           (variable "XDG_DATA_DIRS")
+           (directories '("share")))))
+   (search-paths native-search-paths)
+
    (synopsis "Thread-safe general utility library; basis of GTK+ and GNOME")
    (description
     "GLib provides data structure handling for C, portability wrappers,