summary refs log tree commit diff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-25 02:14:27 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-25 20:51:42 -0400
commitf1466c0caf7837df142020b7f2948045a944f4a8 (patch)
tree10c50a21817ac7c47391814069acfd6e9f60448d /gnu/packages/glib.scm
parent8b8e6118769f4dedb835144c69a63636cb367ad1 (diff)
downloadguix-f1466c0caf7837df142020b7f2948045a944f4a8.tar.gz
gnu: glib: Enable man pages.
* gnu/packages/glib.scm (glib)[arguments]<#:configure-flags>[-Dman]: New flag.
[native-inputs]: Add docbook-xsl.

Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index d29dca2db8..d13ba5998e 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -198,6 +198,7 @@ shared NFS home directories.")
                "bin")) ; glib-mkenums, gtester, etc.; depends on Python
     (arguments
      `(#:disallowed-references (,tzdata-for-tests)
+       #:configure-flags '("-Dman=true")
        #:phases
        (modify-phases %standard-phases
          ;; TODO: Remove the conditional in the next core-updates cycle.
@@ -270,7 +271,8 @@ shared NFS home directories.")
     ;;                                        (assoc-ref %outputs "bin")
     ;;                                        "/bin"))
     (native-inputs
-     `(("gettext" ,gettext-minimal)
+     `(("docbook-xsl" ,docbook-xsl)
+       ("gettext" ,gettext-minimal)
        ("libintl" ,intltool)
        ("m4" ,m4)                       ; for installing m4 macros
        ("perl" ,perl)                   ; needed by GIO tests