summary refs log tree commit diff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-10-01 16:21:15 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 11:00:03 +0000
commitf73758f6c2801c398164a209a529cee78bd9792b (patch)
tree6b0535cf01efc208a25cd89438451d684e82b333 /gnu/packages/glib.scm
parent7b71cd6dab0b44e03e38e32111e01d2e9d32ef99 (diff)
downloadguix-f73758f6c2801c398164a209a529cee78bd9792b.tar.gz
gnu: gobject-introspection: Use python instead of python-wrapper.
'python' is a tiny bit simpler than 'python-wrapper', and is already
used when cross-compiling.  Use it unconditionally.

* gnu/packages/glib.scm (gobject-introspection)[inputs]{python}: Use 'python'
  even when compiling natively.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm4
1 files changed, 1 insertions, 3 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index cbaece6cf1..8117d7904d 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -489,9 +489,7 @@ be used when cross-compiling."
        ("bison" ,bison)
        ("flex" ,flex)))
     (inputs
-     `(,@(if (%current-target-system)
-             `(("python" ,python))
-             `(("python" ,python-wrapper)))
+     `(("python" ,python)
        ("zlib" ,zlib)))
     (propagated-inputs
      `(("glib" ,glib)