summary refs log tree commit diff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-13 17:21:32 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-13 17:21:32 +0200
commit15406013fe63f2ab238eec2d7a8adbc586806ac8 (patch)
tree8377d7c70a925f7c5ea4c04473c4eb547610b64b /gnu/packages/gnome-xyz.scm
parenta3ac317ab4a90f66ac65055fa26dee58ed2367b8 (diff)
parentdd4c1992103a65b8fbdc80fe07a9fe9be822769a (diff)
downloadguix-emacs-team.tar.gz
Merge branch 'master' into emacs-team emacs-team
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm63
1 files changed, 59 insertions, 4 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 4611315e00..0507fc749b 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -19,6 +19,7 @@
 ;;; Copyright © 2022 Eric Bavier <bavier@posteo.net>
 ;;; Copyright © 2022 Sughosha <sughosha@proton.me>
 ;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2023 Eidvilas Markevičius <markeviciuseidvilas@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -296,18 +297,17 @@ shadows, highlights, and gradients for some depth.")
 (define-public flat-remix-gnome-theme
   (package
     (name "flat-remix-gnome-theme")
-    (version "20221107-1")
+    (version "20230508")
     (source
      (origin
        (method git-fetch)
        (uri
         (git-reference
          (url "https://github.com/daniruiz/flat-remix-gnome")
-         ;; This commit adds GtkSourceView 5 theme, for GNOME Text Editor.
-         (commit "b5616efc515e9f1417436e67d94718db7529a2ba")))
+         (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "10fgdz8hz8rd7aj4vb3bvl8khzb2fvaia7n00gi0x19yvnnh36pr"))))
+        (base32 "1b31ayb4qvcr5m3dqcidl9ilpp3w4mr56wq6vrp73g4cj558pi9h"))))
     (build-system copy-build-system)
     (arguments
      `(#:install-plan
@@ -1329,6 +1329,61 @@ Speakers etc. of the same device are also displayed for selection.")
 of windows.")
       (license license:expat))))
 
+(define-public gnome-shell-extension-vitals
+  (package
+    (name "gnome-shell-extension-vitals")
+    (version "62.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/corecoding/Vitals")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0wmw5yd38vyv13x6frbafp21bdhlyjd5ggimdf2696irfhnm828h"))
+              (modules '((guix build utils)))
+              (snippet '(begin
+                          (delete-file "schemas/gschemas.compiled")
+                          (for-each delete-file
+                                    (find-files "locale" "\\.mo$"))))))
+    (build-system copy-build-system)
+    (native-inputs (list `(,glib "bin") gettext-minimal))
+    (inputs (list libgtop))
+    (arguments
+     (list #:modules '((guix build copy-build-system)
+                       (guix build utils)
+                       (ice-9 string-fun))
+           #:phases #~(modify-phases %standard-phases
+                        (add-before 'install 'compile-schemas
+                          (lambda _
+                            (invoke "glib-compile-schemas" "--strict"
+                                    "schemas")))
+                        (add-before 'install 'compile-locales
+                          (lambda _
+                            (for-each (lambda (file)
+                                        (let ((destfile (string-replace-substring
+                                                         file ".po" ".mo")))
+                                          (invoke "msgfmt" "-c" file "-o"
+                                                  destfile)))
+                                      (find-files "locale" "\\.po$")))))
+           #:install-plan #~'(("."
+                               "share/gnome-shell/extensions/Vitals@CoreCoding.com"
+                               #:include-regexp ("\\.js(on)?$" "\\.css$"
+                                                 "\\.ui$"
+                                                 "\\.svg$"
+                                                 "\\.xml$"
+                                                 "\\.mo$"
+                                                 "\\.compiled$")))))
+    (home-page "https://github.com/corecoding/Vitals")
+    (synopsis
+     "GNOME Shell extension displaying computer resource/sensor stats")
+    (description
+     "Vitals is a GNOME Shell extension that can display the computer
+temperature, voltage, fan speed, memory usage and CPU load from the top menu
+bar of the GNOME Shell.")
+    (license license:gpl2+)))
+
 (define-public arc-theme
   (package
     (name "arc-theme")