summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2021-11-13 10:35:26 +0000
committerLudovic Courtès <ludo@gnu.org>2021-11-15 12:15:46 +0100
commit04d53fa8390467c6916fbbb3d950e703a5443a61 (patch)
tree9269c3ca9b7362039def0b3acb1d50982a482b2e /gnu/packages/gnome.scm
parent4b28553e73cd00b7288272615a5105caf31ee692 (diff)
downloadguix-04d53fa8390467c6916fbbb3d950e703a5443a61.tar.gz
gnu: devhelp: Upgrade to 41.2.
* gnu/packages/gnome.scm (devhelp): Upgrade to 41.2 to upgrade the webkit
dependency to 4.1.
[arguments]: Use meson 0.59.
In 'skip-gtk-update-icon-cache' phase, the post install script has been
moved from meson_post_install.py to build-aux/meson/.
In 'fix-devhelp-gir-inputs' phase, the devhelp GIR still mentions webkit
4.0, use 4.1 instead.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f335499c20..17959ed347 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5775,7 +5775,7 @@ both a traditional UI or a modern UI with a GtkHeaderBar.")
 (define-public devhelp
   (package
     (name "devhelp")
-    (version "40.1")
+    (version "41.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
@@ -5783,17 +5783,23 @@ both a traditional UI or a modern UI with a GtkHeaderBar.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "1fvb69l1nyxdrs95ar95rmpfs8nfkpys4x74r8ilid44hhzdk2iy"))))
+                "1lk0gycjvs6gibhy0zs3ffkrkzrkyl5nkp7n60hgpa6syjq91apc"))))
     (build-system meson-build-system)
     (arguments
-     '(#:glib-or-gtk? #t
+     `(#:glib-or-gtk? #t
+       #:meson ,meson-0.59
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'skip-gtk-update-icon-cache
            ;; Don't create 'icon-theme.cache'.
            (lambda _
-             (substitute* "meson_post_install.py"
-               (("gtk-update-icon-cache") "true")))))))
+             (substitute* "build-aux/meson/meson_post_install.py"
+               (("gtk-update-icon-cache") "true"))))
+         (add-after 'unpack 'fix-devhelp-gir-inputs
+           ;; It still mentions webkitgtk 4.0
+           (lambda _
+             (substitute* "devhelp/meson.build"
+               (("'WebKit2-4.0'") "'WebKit2-4.1'")))))))
     (native-inputs
      `(("intltool" ,intltool)
        ("itstool" ,itstool)