summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-04-07 10:54:21 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-04-07 11:18:23 +0200
commit08de1612748c58ace7b77deb5859ac9bb89dd2b2 (patch)
tree7e467c4d46d27aa1c5436f76bc30f473795dbefa /gnu/packages/gnome.scm
parent80d364b92b73e6757f2c9a703582519655bb4f5c (diff)
downloadguix-08de1612748c58ace7b77deb5859ac9bb89dd2b2.tar.gz
gnu: Fix builds that require old blueprint-compiler.
This is a follow-up commit to cee21ef8650d723e9e1ea4c6313897fd3bf64112 and
fixes two builds that rely on an older version of blueprint-compiler.
The giara package remains broken as a result of a test failure.

* gnu/packages/gnome.scm (blueprint-compiler-0.4): New variable.
* gnu/packages/syndication.scm (giara, gfeeds): Replace blueprint-compiler
with blueprint-compiler-0.4.
* gnu/packages/text-editors.scm (textpieces): Likewise
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6fe8d2ee44..4934ade3dd 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3320,6 +3320,22 @@ compiles to GTKBuilder XML.")
     (home-page "https://gitlab.gnome.org/jwestman/blueprint-compiler")
     (license license:lgpl3+)))
 
+(define-public blueprint-compiler-0.4
+  (package
+    (inherit blueprint-compiler)
+    (name "blueprint-compiler")
+    (version "0.4.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url
+                     "https://gitlab.gnome.org/jwestman/blueprint-compiler")
+                    (commit (string-append "v" version))))
+              (file-name (string-append name "-" version "-checkout"))
+              (sha256
+               (base32
+                "0hj7f4xhwjc4x32r3lswwclbw37fw3spy806g4plkmym25hz4ydy"))))))
+
 (define-public cambalache
   (package
     (name "cambalache")