summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-08-02 20:54:34 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 23:11:16 +0200
commit14528483fb78fbeb8fcb6136c080799b58b31854 (patch)
treee5d7fd4e1ee1457501586ab55ab336754ee93654 /gnu/packages/gnome.scm
parent7295171e264260acfc7e44c08f0b56641c01d107 (diff)
downloadguix-14528483fb78fbeb8fcb6136c080799b58b31854.tar.gz
gnu: seed: Fix tests.
* gnu/packages/gnome.scm (seed)[arguments]<#:phases>[patch-tests]: New phase.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2abb73a175..6923522e18 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -329,6 +329,12 @@ bindings.")
                         "configure"
                         "Makefile.in"))
              #t))
+         (add-after 'unpack 'patch-tests
+           (lambda* (#:key outputs #:allow-other-keys)
+             (substitute* (find-files "." "\\.js$")
+              (("#!/usr/bin/env seed")
+               (string-append "#!" (getcwd) "/src/seed")))
+             #t))
          (add-before 'build 'patch-docbook-xml
            (lambda* (#:key inputs #:allow-other-keys)
              (with-directory-excursion "doc"