summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-09 19:52:10 +0100
committerMarius Bakke <marius@gnu.org>2020-11-09 22:08:10 +0100
commit1564d1fd96dd956ca4315516329392073d1ee375 (patch)
tree75b5db2c7d3a5cb80c62016b8357da0f6baae366 /gnu/packages/gnome.scm
parent98a15c796afcc91894b7400b1d548cd50604db0c (diff)
downloadguix-1564d1fd96dd956ca4315516329392073d1ee375.tar.gz
gnu: totem: Fix test failure with GStreamer 1.18.
* gnu/packages/gnome.scm (totem)[arguments]: Add phase "patch-failing-test".
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 17cdc93a00..8c3b739083 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6077,6 +6077,14 @@ discovery protocols.")
              (substitute* "meson_post_install.py"
                (("gtk-update-icon-cache") "true"))
              #t))
+         (add-after 'unpack 'patch-failing-test
+           (lambda _
+             ;; Work around test failure with GStreamer 1.18, because the test
+             ;; relies on "und" not being mapped to a particular language:
+             ;; https://gitlab.gnome.org/GNOME/totem/-/issues/450
+            (substitute* "src/test-totem.c"
+              (("und") "nosuchlang"))
+            #t))
          (add-before
           'install 'disable-cache-generation
           (lambda _