summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-12-18 03:58:23 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-12-18 03:58:23 +0100
commit256d5b3598fa2162e9712fc98781d2cb4ceda31e (patch)
tree0e7f7051a59aad879561b5c4ee885e24d3c04bc6 /gnu/packages/gnome.scm
parent9f6210cc5c114310a38ad1cc0ff5900409a7e7cc (diff)
parent1a9f267f51f97b8ca7049aa72763ddd64aad5b62 (diff)
downloadguix-256d5b3598fa2162e9712fc98781d2cb4ceda31e.tar.gz
Merge branch 'master' into wip-webkit
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm55
1 files changed, 45 insertions, 10 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a0a7d268e9..b0417b2df9 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3586,11 +3586,19 @@ for dealing with different structured file formats.")
               ;; https://gitlab.gnome.org/GNOME/librsvg/-/issues/955).
               (substitute* "gdk-pixbuf-loader/librsvg.thumbnailer.in"
                 (("@bindir@/gdk-pixbuf-thumbnailer")
-                 (search-input-file inputs "bin/gdk-pixbuf-thumbnailer")))))
+                 (string-append #$(this-package-input "gdk-pixbuf")
+                                "/bin/gdk-pixbuf-thumbnailer")))))
           (add-after 'unpack 'prepare-for-build
             (lambda _
               ;; In lieu of #:make-flags
               (setenv "CC" #$(cc-for-target))
+              (setenv "PKG_CONFIG" #$(pkg-config-for-target))
+              (when #$(%current-target-system)
+                (setenv "RUST_TARGET"
+                        (string-replace
+                          #$(%current-target-system)
+                          "-unknown-linux-gnu"
+                          (string-index #$(%current-target-system) #\-))))
               ;; Something about the build environment resists building
               ;; successfully with the '--locked' flag.
               (substitute* '("Makefile.am" "Makefile.in")
@@ -3623,9 +3631,18 @@ for dealing with different structured file formats.")
               (apply (assoc-ref gnu:%standard-phases 'configure)
                      #:configure-flags
                      (list "--disable-static"
-                           "--enable-vala"
-                           (string-append "--with-html-dir=" #$output
-                                          "/share/gtk-doc/html"))
+                           #$@(if (%current-target-system)
+                                #~(;; g-ir-scanner can't import its modules
+                                   ;; and vala currently can't be cross-compiled.
+                                   "--enable-introspection=no"
+                                   "--enable-vala=no"
+                                   ;; These two are necessary for cross-compiling.
+                                   (string-append
+                                     "--build=" #$(nix-system->gnu-triplet
+                                                    (%current-system)))
+                                   (string-append
+                                     "--host=" #$(%current-target-system)))
+                                #~("--enable-vala")))
                      args)))
           (add-after 'configure 'dont-vendor-self
             (lambda* (#:key vendor-dir #:allow-other-keys)
@@ -3635,13 +3652,14 @@ for dealing with different structured file formats.")
           (replace 'build
             (assoc-ref gnu:%standard-phases 'build))
           (replace 'check
-            (lambda* args
-              ((assoc-ref gnu:%standard-phases 'check)
-               #:test-target "check")))
+            (lambda* (#:key tests? #:allow-other-keys #:rest args)
+              (when tests?
+                ((assoc-ref gnu:%standard-phases 'check)
+                 #:test-target "check"))))
           (replace 'install
             (assoc-ref gnu:%standard-phases 'install)))))
-    (native-inputs (list `(,glib "bin") gobject-introspection pkg-config vala))
-    (inputs (list freetype harfbuzz libxml2 pango))
+    (native-inputs (list gdk-pixbuf `(,glib "bin") gobject-introspection pkg-config vala))
+    (inputs (list freetype gobject-introspection harfbuzz libxml2 pango))
     (propagated-inputs (list cairo gdk-pixbuf glib))
     (synopsis "SVG rendering library")
     (description "Librsvg is a library to render SVG images to Cairo surfaces.
@@ -8750,8 +8768,25 @@ the available networks and allows users to easily switch between them.")
 library.")
     (license license:lgpl2.1+)))
 
-;; This is the last release providing the 2.6 API, hence the name.
 ;; This is needed by tascam-gtk
+(define-public libxml++-3
+  (package
+    (inherit libxml++)
+    (name "libxml++")
+    (version "3.2.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/libxmlplusplus/libxmlplusplus")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "07f6l9ka63dnc85npxq5g7bn1ja7lad0w2wixqdlyabdvc4l2hp5"))))
+    (propagated-inputs (modify-inputs (package-propagated-inputs libxml++)
+                         (append glibmm-2.64)))))
+
+;; This is the last release providing the 2.6 API, hence the name.
 (define-public libxml++-2
   (package
     (inherit libxml++)