summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-01-02 23:56:30 +0100
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-01-07 19:34:18 +0100
commit364bc7a01b2fe41410c684b1f3c8c825085d7d1f (patch)
treec3a044e64dd320480a00d4f0e0d655d8c9d587be /gnu/packages/gnome.scm
parent0759cde4fe97b7dc467ea7ce7b121a9a0e44a78a (diff)
downloadguix-364bc7a01b2fe41410c684b1f3c8c825085d7d1f.tar.gz
gnu: arc-theme: Move to gnome-xyz.
* gnu/packages/gnome.scm (arc-theme): Move from here...
* gnu/packages/gnome-xyz.scm (arc-theme): ... to here.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm44
1 files changed, 0 insertions, 44 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f0d94ab1fe..b499684aee 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9570,50 +9570,6 @@ functionality and behavior.")
     (home-page "https://extensions.gnome.org/")
     (license license:gpl3+)))
 
-(define-public arc-theme
-  (package
-    (name "arc-theme")
-    (version "20201013")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/jnsh/arc-theme")
-                    (commit version)))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1x2l1mwjx68dwf3jb1i90c1q8nqsl1wf2zggcn8im6590k5yv39s"))))
-    (build-system gnu-build-system)
-    (arguments
-     '(#:configure-flags
-       (list "--disable-cinnamon")
-       #:phases
-       (modify-phases %standard-phases
-         ;; autogen.sh calls configure at the end of the script.
-         (replace 'bootstrap
-           (lambda _ (invoke "autoreconf" "-vfi")))
-         (add-before 'build 'set-home   ;placate Inkscape
-           (lambda _
-             (setenv "HOME" (getcwd))
-             #t)))))
-    (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("glib" ,glib "bin")             ; for glib-compile-resources
-       ("gnome-shell" ,gnome-shell)
-       ("gtk+" ,gtk+)
-       ("inkscape" ,inkscape)
-       ("optipng" ,optipng)
-       ("pkg-config" ,pkg-config)
-       ("sassc" ,sassc/libsass-3.5)))
-    (synopsis "A flat GTK+ theme with transparent elements")
-    (description "Arc is a flat theme with transparent elements for GTK 3, GTK
-2, and GNOME Shell which supports GTK 3 and GTK 2 based desktop environments
-like GNOME, Unity, Budgie, Pantheon, XFCE, Mate, etc.")
-    (home-page "https://github.com/horst3180/arc-theme")
-    ;; No "or later" language found.
-    (license license:gpl3+)))
-
 (define-public faba-icon-theme
   (package
     (name "faba-icon-theme")