summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-10 01:59:34 +0200
committerMarius Bakke <marius@gnu.org>2022-09-10 20:08:38 +0200
commit42bbe4d8ba8d12ddbd611796d68f4c2cdcbf2086 (patch)
treef84211484c2cdedb07c2f0720bfc7539cca68ec1 /gnu/packages/gnome.scm
parentade18d4c9e1fbf7ab16f341f5250cf440439411e (diff)
downloadguix-42bbe4d8ba8d12ddbd611796d68f4c2cdcbf2086.tar.gz
gnu: mutter: Update to 42.4.
* gnu/packages/gnome.scm (mutter): Update to 42.4.
[arguments]: Adjust link flags for new soversion.  Don't install tests.  Add
phase to preserve RUNPATH.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 97b1e36465..546fa8c625 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7396,7 +7396,7 @@ to display dialog boxes from the commandline and shell scripts.")
 (define-public mutter
   (package
     (name "mutter")
-    (version "41.0")
+    (version "42.4")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
@@ -7404,7 +7404,7 @@ to display dialog boxes from the commandline and shell scripts.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "17pqrm48kddqrc3fl96n5knhaxyn0crg0zv7zpmqhk848jks307s"))))
+                "0h1ak3201mdc2qbf67fhcn801ddp33hm0f0c52zis1l7s6ipyb62"))))
     ;; NOTE: Since version 3.21.x, mutter now bundles and exports forked
     ;; versions of cogl and clutter.  As a result, many of the inputs,
     ;; propagated-inputs, and configure flags used in cogl and clutter are
@@ -7423,9 +7423,12 @@ to display dialog boxes from the commandline and shell scripts.")
       #~(list
          ;; Otherwise, the RUNPATH will lack the final path component.
          (string-append "-Dc_link_args=-Wl,-rpath="
-                        #$output "/lib:" #$output "/lib/mutter-9")
+                        #$output "/lib,-rpath="
+                        #$output "/lib/mutter-10")
          ;; Disable systemd support.
          "-Dsystemd=false"
+         ;; Don't install tests.
+         "-Dinstalled_tests=false"
          ;; The following flags are needed for the bundled clutter
          (string-append "-Dxwayland_path="
                         (search-input-file %build-inputs "/bin/Xwayland"))
@@ -7439,6 +7442,13 @@ to display dialog boxes from the commandline and shell scripts.")
       #:test-options ''("--verbose")
       #:phases
       #~(modify-phases %standard-phases
+          (add-after 'unpack 'use-RUNPATH-instead-of-RPATH
+            (lambda _
+              ;; The build system disables RUNPATH in favor of RPATH to work
+              ;; around a peculiarity of their CI system.  Ignore that.
+              (substitute* "meson.build"
+                (("disable-new-dtags")
+                 "enable-new-dtags"))))
           (add-after 'unpack 'patch-dlopen-calls
             (lambda* (#:key inputs #:allow-other-keys)
               (substitute* "src/wayland/meta-wayland-egl-stream.c"