summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorKaelyn Takata <kaelyn.alexi@protonmail.com>2023-04-03 16:37:58 +0000
committerAndreas Enge <andreas@enge.fr>2023-04-08 11:41:05 +0200
commit57627eedc883324bbc0f15cdaf453f72f90ebb39 (patch)
tree7c8df426c9f75c5e7b3fbae80b350a3583e0da10 /gnu/packages/gnome.scm
parent0d1cd5f1d72d1d1c4bfeb8593e19bb4e15a8827a (diff)
downloadguix-57627eedc883324bbc0f15cdaf453f72f90ebb39.tar.gz
gnu: librsvg-2.40: Fix test failure with Pango 1.50.
* gnu/packages/gnome.scm (librsvg-2.40): Fix test failure with Pango 1.50.

Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e81882b181..970ab9b873 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -73,6 +73,7 @@
 ;;; Copyright © 2022 Rene Saavedra <nanuui@protonmail.com>
 ;;; Copyright © 2022 Alexandros Theodotou <alex@zrythm.org>
 ;;; Copyright © 2022 Arjan Adriaanse <arjan@adriaan.se>
+;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3725,6 +3726,12 @@ diagrams.")
                (("gdk_pixbuf_cache_file = .*$")
                 "gdk_pixbuf_cache_file = $(TMPDIR)/loaders.cache\n"))
              #t))
+         (add-before 'check 'fix-test-with-pango-1.50
+           (lambda _
+	     ;; Changes between pango 1.48 and 1.50 caused the text to be one
+	     ;; pixel lower in the output image compared to the reference.
+             (substitute* "tests/fixtures/reftests/bugs/587721-text-transform.svg"
+	       (("660\\.9") "659.9"))))
          (add-before 'check 'remove-failing-tests
            (lambda _
              (with-directory-excursion "tests/fixtures/reftests"