summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-04 22:19:31 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 00:20:38 -0400
commit6a82d5a9ae661249f6c17ed61c3731e19ee5ba85 (patch)
tree566a7fe064ee5a9730db4bd4974152cbeaf6d1b6 /gnu/packages/gnome.scm
parent560a47aa9331d8d293701746bdb460a0071338c1 (diff)
downloadguix-6a82d5a9ae661249f6c17ed61c3731e19ee5ba85.tar.gz
gnu: Add rest-next.
* gnu/packages/gnome.scm (rest-next): New variable.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 654032ba25..6fd87cc978 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4902,6 +4902,46 @@ claim to be \"RESTful\".  It includes convenience wrappers for libsoup and
 libxml to ease remote use of the RESTful API.")
     (license license:lgpl2.1+)))
 
+(define-public rest-next
+  (package
+    (inherit rest)
+    (name "rest")
+    (version "0.9.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/rest/"
+                                  (version-major+minor version) "/"
+                                  name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1qy2291d2vprdbbxmf0sa98izk09nl3znzzv7lckwf6f1v0sarlj"))))
+    (build-system meson-build-system)
+    (arguments (substitute-keyword-arguments (package-arguments rest)
+                 ((#:tests? _ #f) #t)
+                 ((#:configure-flags _)
+                  #~(list))
+                 ((#:phases phases '%standard-phases)
+                  #~(modify-phases #$phases
+                      (add-after 'unpack 'disable-problematic-tests
+                        ;; These tests require networking.
+                        (lambda _
+                          (substitute* "tests/meson.build"
+                            ((".*'flickr',.*") "")
+                            ((".*'lastfm',.*") ""))))
+                      (add-before 'check 'prepare-for-tests
+                        (lambda _
+                          (setenv "HOME" "/tmp")))))))
+    (native-inputs
+     (modify-inputs (package-native-inputs rest)
+       (append gettext-minimal
+               gi-docgen
+               gsettings-desktop-schemas)))
+    (inputs (list gtksourceview json-glib libadwaita))
+    (propagated-inputs
+     (modify-inputs (package-propagated-inputs rest)
+       (replace "libsoup" libsoup)
+       (append json-glib)))))
+
 ;;; A minimal version of libsoup used to prevent a cycle with Inkscape.
 (define-public libsoup-minimal
   (package