summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2021-11-30 00:05:18 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-12-01 10:01:44 +0100
commit762643e0fc2b4c6fe06ac0e15f7352c85d801777 (patch)
treea535822a17a0830b167d3e6f60d9b8427800fd5c /gnu/packages/gnome.scm
parent89907521ef2f8845f13369b95376cefa22a9320d (diff)
downloadguix-762643e0fc2b4c6fe06ac0e15f7352c85d801777.tar.gz
gnu: gnome-builder: Use libsoup 2.
* gnu/packages/gnome.scm (gnome-builder) [phase 'patch-meson]: Don’t search
for webkit2gtk-4.1.
[inputs]: Replace devhelp with devhelp-with-libsoup2 and
webkit with webkit-with-libsoup2.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ccb99ca8ec..5f99616571 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12486,10 +12486,7 @@ libraries.  Applications do not need to be recompiled--or even restarted.")
              (substitute* "src/libide/meson.build"
                (("/usr/lib")
                 (string-append (assoc-ref inputs "python-pygobject")
-                               "/lib")))
-             (substitute* "meson.build"
-               (("webkit2gtk-4.0") "webkit2gtk-4.1"))
-             #t))
+                               "/lib")))))
          (add-after 'configure 'fix-ninja
            (lambda _
              ;; #43296: meson(?) incorrectly assumes we want to link
@@ -12505,7 +12502,7 @@ libraries.  Applications do not need to be recompiled--or even restarted.")
     (inputs
      `(("cmark" ,cmark)
        ("clang" ,clang)
-       ("devhelp" ,devhelp)
+       ("devhelp" ,devhelp-with-libsoup2)
        ("glade" ,glade3)
        ("gspell" ,gspell)
        ("gtk+" ,gtk+)
@@ -12521,7 +12518,7 @@ libraries.  Applications do not need to be recompiled--or even restarted.")
        ("sysprof" ,sysprof)
        ("template-glib" ,template-glib)
        ("vte" ,vte)
-       ("webkitgtk" ,webkitgtk)))
+       ("webkitgtk" ,webkitgtk-with-libsoup2)))
     (propagated-inputs
      `(("gtksourceview" ,gtksourceview)))         ;needed for settings
     (native-inputs